jmeter-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 61679] New: jmeter doesn't start with Java 9.0.1
Date Fri, 27 Oct 2017 14:27:42 GMT
https://bz.apache.org/bugzilla/show_bug.cgi?id=61679

            Bug ID: 61679
           Summary: jmeter doesn't start with Java 9.0.1
           Product: JMeter
           Version: 3.3
          Hardware: PC
            Status: NEW
          Severity: major
          Priority: P2
         Component: Main
          Assignee: issues@jmeter.apache.org
          Reporter: romanlevin@gmail.com
  Target Milestone: ---

After installing jmeter, it fails to start:
```shell
$ jmeter
Error: Java version is too low to run JMeter. Needs at least Java >= 1.8.0
```

This because of this bit of shell script in
`/usr/local/Cellar/jmeter/3.3/libexec/bin/jmeter`:
```sh
# Minimal version to run JMeter
MINIMAL_VERSION=1.8.0

# Check if Java is present and the minimal version requirement
_java=`type java | awk '{ print $ NF }'`
CURRENT_VERSION=`"$_java" -version 2>&1 | awk -F'"' '/version/ {print $2}'`
minimal_version=`echo $MINIMAL_VERSION | awk -F'.' '{ print $2 }'`
current_version=`echo $CURRENT_VERSION | awk -F'.' '{ print $2 }'`
if [ $current_version ]; then
        if [ $current_version -lt $minimal_version ]; then
                 echo "Error: Java version is too low to run JMeter. Needs at
least Java >= ${MINIMAL_VERSION}." 
                 exit 1
        fi
    else
         echo "Not able to find Java executable or version. Please check your
Java installation."
         exit 1
fi
```
which compares the `8` in `1.8.0` to the `0` in `9.0.1` (the `java` cask), thus
deciding Java 9 is too old.

This is a [known
issue](https://stackoverflow.com/questions/38128132/cant-run-jmeter-on-os-x-el-capitan).

-- 
You are receiving this mail because:
You are the assignee for the bug.
Mime
View raw message