jmeter-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: Remove "or later" words into "Requires Java 8 or later"
Date Sat, 23 Sep 2017 11:39:44 GMT
On 23 September 2017 at 12:28, Felix Schumacher
<felix.schumacher@internetallee.de> wrote:
>
>
> Am 23. September 2017 01:27:13 MESZ schrieb sebb <sebbaz@gmail.com>:
>>On 22 September 2017 at 19:53, Milamber <milamber@apache.org> wrote:
>>> Hello,
>>>
>>> I thinks we need to remove the "or later" words from these pages
>>because
>>> JMeter (out of the box) won't start with Java 9
>>>
>>> Note: of course you can start JMeter 3.3 with Java 9 with some tweaks
>>to
>>> disable the check of Java version from launch scripts.
>>
>>Does the Java check provide any benefit?
>>
>>Why not drop the code?
>
> I think we could reduce the code to log a warning, rather than exiting.

But AFAICT this will still not work for Java 9 (or the code would not
need to be fixed to work with Java 9!)

What benefit does the check provide?

AFAICT it only avoids the java.lang.UnsupportedClassVersionError.

Do we really need to prevent people seeing that?

> Felix
>
>>
>>> Are you ok for I updated these pages?
>>>
>>> http://jmeter.apache.org/download_jmeter.cgi
>>> https://www.apache.org/dist/jmeter/
>>>
>>> Milamber

Mime
View raw message