jmeter-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Milamber <milam...@apache.org>
Subject Re: svn commit: r1772959 - /jmeter/trunk/build.xml
Date Wed, 07 Dec 2016 10:48:48 GMT

Yes I use Java 8

The issue that Ant < 1.9 isn't compatible with Java 8

http://stackoverflow.com/questions/20702626/javac1-8-class-not-found

Works with this command (ant 1.8.4) :
ant -Djmeter.version=3.2-SNAPSHOT -Duser.name=milamber@apache.org 
-Dbuild.compiler=javac1.7 distribution

On 07/12/2016 05:36, Felix Schumacher wrote:
> Have you setup the variable JAVA_HOME to point to your jdk 8 setup?
>
> Felix
>
> Am 6. Dezember 2016 22:35:13 MEZ, schrieb Milamber <milamber@apache.org>:
>> I'm not sure that will works:
>>
>> $ ant -Djmeter.version=3.2-SNAPSHOT -Duser.name=milamber@apache.org
>> distribution
>> Buildfile: /home/milamber/temp/jmetertemp/build.xml
>>
>> _check_ant-version:
>>
>> ant-version:
>>      [echo] ant.version = Apache Ant(TM) version 1.8.4 compiled on May
>> 22 2012
>>
>> svnCheck:
>>       [echo] svn.revision=1772959
>>
>> check-versions:
>>
>> clean:
>>
>> _check_3rdparty:
>>
>> _message_3rdParty:
>>
>> compile-slf4j_logkit:
>> [mkdir] Created dir: /home/milamber/temp/jmetertemp/build/slf4j-logkit
>>
>> BUILD FAILED
>> /home/milamber/temp/jmetertemp/build.xml:828: Class not found: javac1.8
>>
>> Total time: 1 second
>>
>>
>> On 06/12/2016 21:08, fschumacher@apache.org wrote:
>>> Author: fschumacher
>>> Date: Tue Dec  6 21:08:09 2016
>>> New Revision: 1772959
>>>
>>> URL: http://svn.apache.org/viewvc?rev=1772959&view=rev
>>> Log:
>>> travis-ci needs an older version of ant.
>>>
>>> Modified:
>>>       jmeter/trunk/build.xml
>>>
>>> Modified: jmeter/trunk/build.xml
>>> URL:
>> http://svn.apache.org/viewvc/jmeter/trunk/build.xml?rev=1772959&r1=1772958&r2=1772959&view=diff
>> ==============================================================================
>>> --- jmeter/trunk/build.xml (original)
>>> +++ jmeter/trunk/build.xml Tue Dec  6 21:08:09 2016
>>> @@ -85,7 +85,7 @@
>>>      -->
>>>    
>>>      <!-- Minimal version of Apache Ant requiere by this Ant script
>> -->
>>> -  <property name="ant.version.required" value="1.9.1" />
>>> +  <property name="ant.version.required" value="1.8.2" />
>>>    
>>>      <!-- Are we running under Gump? -->
>>>      <property name="gump.run" value="false"/>
>>>
>>>
>>>


Mime
View raw message