jmeter-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Philippe Mouawad <philippe.moua...@gmail.com>
Subject Re: broken builds on travis ci
Date Wed, 23 Nov 2016 21:48:00 GMT
On Wed, Nov 23, 2016 at 9:57 PM, Felix Schumacher <
felix.schumacher@internetallee.de> wrote:

> Hi all,
>
> with pr #234 I succeeded to get the builds on travis ci back to green. I
> had to change three things on the way:
>
Great

>
>  1. Start the rmi server in the batch tests with localhost as host name,
> since travis ci runs with the hostname bound to loopback and JMeter refuses
> to start in such a constellation (you might have a look at
> https://bugs.launchpad.net/ubuntu/+source/jakarta-jmeter/+bug/589042,
> where such a problem has been discussed before, alas without travis ci :)
>
>  2. Revert to ant 1.8.2 compatibility as that is the version running on
> travis. My solution to replace "if:set" with "condition" feels a bit clumsy.
>
This may be a problem with Java 8 . I remember I had to upgrade when using
Java8.

>
>  3. Disable two tests HTTP_HTTPS and BUG52310, which are either
> problematic because of some strange dns problem or maybe some firewall
> issue.
>

What test exactly.
52310 may not be too problematic , but the one with HTTP/ HTTPS is more
important, I remember one of my commits had broken an important part.

>
> I would like to apply these changes to trunk. What do you think?
>
+1

>
> Felix
>
>


-- 
Cordialement.
Philippe Mouawad.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message