jmeter-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Milamber <milam...@apache.org>
Subject Re: buildbot failure in on jmeter-trunk [Tag: Ant, Buildbot]
Date Sun, 13 Nov 2016 16:37:00 GMT


On 13/11/2016 13:06, sebb wrote:
> On 13 November 2016 at 12:40, Felix Schumacher
> <felix.schumacher@internetallee.de> wrote:
>> Am 13.11.2016 13:34, schrieb Milamber:
>>> Hello,
>>>
>>> With commit 1769490, I force the usage of Ant > 1.9.1 for JMeter.
>>>
>>> I've open a Infra ticket [1] to have a more recent version of Ant for
>>> the CI buildbot task. (currently I thinks it's Ant 1.8.2)
>>>
>>> Already says, this issue isn't a blocker for the 3.1 RC3. I will start
>>> the release process in few hours.
>>>
>>> Milamber
>>>
>>> For the record (in this mailing list) :
>>> - original JMeter buildbot request [2]
>>> - current JMeter buildbot config file [3]
>>
>> Hemera as a build slave will be gone by the 30. November. I have changed the
>> slaves to bb_slave1_ubuntu in [3] as suggested by infra. But it seems that
>> changing [3] is not enough.
> AFAIK, some config changes need to be manually applied.
> You might need to ask Infra to do so.


I've just update the Infra ticket to indicate this.



>
>> So hopefully your ticket will help.
>>
>> Regards,
>>   Felix
>>
>>
>>> [1] https://issues.apache.org/jira/browse/INFRA-12903
>>> [2] https://issues.apache.org/jira/browse/INFRA-4025
>>> [3]
>>>
>>> https://svn.apache.org/repos/infra/infrastructure/buildbot/aegis/buildmaster/master1/projects/jmeter.conf
>>>
>>>
>>>
>>> On 13/11/2016 11:26, Milamber wrote:
>>>>
>>>>
>>>> Root cause :
>>>>
>>>> "The if/unless namespaces are only available since Ant 1.9.1."
>>>> the if/unless namespaces was introduced with Bugzilla 60364
>>>>
>>>>
>>>> http://stackoverflow.com/questions/35393545/how-can-i-provide-a-conditional-jvmarg-for-the-ant-junit-command
>>>> On 13/11/2016 10:23, Milamber wrote:
>>>>>
>>>>>
>>>>> On 13/11/2016 10:04, Philippe Mouawad wrote:
>>>>>> Hi,
>>>>>> Can we upgrade ant on build bot ?
>>>>>
>>>>> I don't know.
>>>>>
>>>>>
>>>>> The error come because the call of org.apache.jorphan.test.AllTests in
>>>>> _test task don't have the jacocoagent property (with ant 1.8). Currently
I
>>>>> try to find a bypass like the test.headless property...
>>>>>
>>>>>> Do you plan the release today ?
>>>>>
>>>>> yes, i would like. But this buildbot error is annoying even if not a
>>>>> blocker to build JMeter (if I use a Ant > 1.9)
>>>>>
>>>>> Milamber
>>>>>
>>>>>> Thanks
>>>>>>
>>>>>> On Sunday, November 13, 2016, Milamber <milamber@apache.org>
wrote:
>>>>>>
>>>>>>> I can reproduce this error with Ant 1.8.4. (works fine with Ant
1.9.7)
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> On 12/11/2016 20:41, Philippe Mouawad wrote:
>>>>>>>
>>>>>>>> Hello,
>>>>>>>> I don't know how to fix this issue on buildbox.
>>>>>>>> It's not happening on jenkins.
>>>>>>>>
>>>>>>>> Regards
>>>>>>>>
>>>>>>>> On Sat, Nov 12, 2016 at 4:23 PM, <buildbot@apache.org>
wrote:
>>>>>>>>
>>>>>>>> The Buildbot has detected a new failure on builder jmeter-trunk
while
>>>>>>>>> building . Full details are available at:
>>>>>>>>> https://ci.apache.org/builders/jmeter-trunk/builds/1621
>>>>>>>>>
>>>>>>>>> Buildbot URL: https://ci.apache.org/
>>>>>>>>>
>>>>>>>>> Buildslave for this Build: hemera_ubuntu
>>>>>>>>>
>>>>>>>>> Build Reason: The AnyBranchScheduler scheduler named
>>>>>>>>> 'on-jmeter-commit'
>>>>>>>>> triggered this build
>>>>>>>>> Build Source Stamp: [branch jmeter/trunk] 1769389
>>>>>>>>> Blamelist: pmouawad
>>>>>>>>>
>>>>>>>>> BUILD FAILED: failed shell_3
>>>>>>>>>
>>>>>>>>> Sincerely,
>>>>>>>>>     -The Buildbot
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>
>>>>


Mime
View raw message