jmeter-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John_schulz <john_sch...@aol.com>
Subject Re: Drop MongoDB support ?
Date Sat, 19 Dec 2015 15:21:53 GMT
IMHO the current jmeter mongodb driver is of limited usefulness anyway. It would be nice to
have one that fully supports the newer mongodb API. Retaining the current relatively useless
one is of marginal value.

John 

Sent from my iPad

> On Dec 19, 2015, at 9:49 AM, Philippe Mouawad <philippe.mouawad@gmail.com> wrote:
> 
> Hello,
> Current MongoDB test elements use Mongodb java driver 2.11.
> Last 2.X version is 2.14.0 and it is now advised to use 3.X which uses an
> asynch model.
> 
> Migrating to 2.14 introduces some deprecations which would need fixing.
> Migrating to 3 requires more work and may be incompatible with JMeter
> threading mondel.
> But  I wonder if it's useful to still maintain this element in JMeter:
> - I don't see JMeter referenced on MongoDB website
> - Looking into stackoverflow I don't neither see many questions (2),
> http://stackoverflow.com/search?q=[jmeter]+%2Bmongo
> - AFAIK, we only got 1 question on MongoDB
> 
> What's your opinion ?
> 
> Regards
> Philippe

Mime
View raw message