jmeter-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: HttpCore 4.2: waiting release after 2.7 (and Commons IO 2.3)
Date Tue, 15 May 2012 15:07:22 GMT
On 14 May 2012 21:33, Milamber <milamber@apache.org> wrote:
>
>
> Le 13/05/2012 23:10, sebb a ecrit :
>> On 13 May 2012 21:25, Milamber <milamber@apache.org> wrote:
>>
>>> Hello,
>>>
>>> I thinks that is better to wait the release after JMeter 2.7 to upgrade
>>> HttpComponents HttpCore to 4.2 (currently 4.1.4).
>>> http://mail-archives.apache.org/mod_mbox/www-announce/201205.mbox/%3C1336239139.2137.34.camel%40ubuntu%3E
>>>
>> Not sure why you suggest waiting.
>> Though of course we need to check that it is suitable for use with the
>> current HttpClient release.
>>
>
> Because, perhaps, a httpcore 4.2 update may introduce some hidden bug
> just before the release. But you are right, the update can be made
> before release with some checks. I can do this if your are ok.
>
>>
>>> On http://www.apache.org/dist/httpcomponents/httpcore/RELEASE_NOTES.txt
>>> "new asynchronous client and server side protocol handlers", seems
>>> important for the Parallel Controller discussion.
>>>
>> I doubt we need to move to aynch. IO for that.
>> After all, we already support parallel requests in different threads.
>>
>
>
> Basic async request is used in HTTPSamplerBase for parallel download of
> embedded resources.

Huh?

AFAICT, we use the standard HTTPSampler sample() method in a separate thread.

We don't use Asynch I/O.

> Perhaps that is a opportunity to study the async
> httpclient api for the parallel controller discussion (or embedded
> resources)

Perhaps, but from what I have read on the HC mailing list it's only
really necessary for very high numbers of parallel requests.

> Milamber
>
>>
>>> With Commons IO 2.3, Java 1.6 is needed.
>>> http://mail-archives.apache.org/mod_mbox/www-announce/201204.mbox/%3CCACZkXPznzeiMdT%3DU%3DcLR16G2CKJJUiGzrt501rBREk3aZYxq6A%40mail.gmail.com%3E
>>>
>> We should only upgrade to IO 2.3 once we start needing 1.6 elsewhere,
>> rather than being forced to use 1.6 because of IO 2.3.
>> I don't think we make extensive use of Commons IO, so there is no
>> particular need to update it.
>>
>>
>>> After JMeter 2.7 release, I will start the Java 1.6 conversion
>>> (@override tags, System Tray Icon, etc.)
>>>
>> Yes.
>>
>>
>>> Any comments are welcome.
>>>
>>> Milamber
>>>
>>>
>>>
>>>
>>>
>>
>

Mime
View raw message