jena-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andy Seaborne <andy.seabo...@epimorphics.com>
Subject Re: TDB versus arq and jena versions
Date Fri, 10 Dec 2010 16:54:42 GMT


On 10/12/10 15:52, Benson Margulies wrote:
> Does TDB 0.8.7 not get along with arq 2.8.6? The pom in the package
> cries out for 2.8.7-RC-2 of arq and 2.6.4-RC-1, and those aren't on
> central.
>
> testVerySimpleQuery(com.basistech.jug.rdfdb.SimpleRoundTripTest)  Time
> elapsed: 0.81 sec<<<  ERROR!
> java.lang.NoClassDefFoundError: com/hp/hpl/jena/sparql/modify/UpdateVisitor
> 	at com.hp.hpl.jena.tdb.TDB.initialization1(TDB.java:203)
> 	at com.hp.hpl.jena.tdb.TDB.<clinit>(TDB.java:186)
> 	at com.basistech.jug.rdfdb.jena.JenaStore.initialize(JenaStore.java:59)

http://repo2.maven.org/maven2/com/hp/hpl/jena/tdb/0.8.7/tdb-0.8.7.pom

POM for TDB 0.8.7 says:

<ver.jena>2.6.3</ver.jena>
<ver.arq>2.8.5</ver.arq>

It looks like you have POM for TDB0.8.8-SNAPSHOT which calls for 
ARQ-2.8.7-RC-2 and Jena-2.6.4-RC-1 (currently):

SNAPSHOTs and RC's don't go to central.  You can get them from
http://openjena.org/repo-dev/

Mix-and-match versions will not work (lots of internal reorganisation).

	Andy

Mime
View raw message