james-server-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From MichaƂ Cukierman <of...@partbook.eu>
Subject Problem with discovering ip/dns names
Date Fri, 10 Sep 2010 10:51:08 GMT
Hi,

I have aa problem with dns resolving names in James 3.0, i stil have a
"." in smtp/imap service instead of ip or name.

When connection with my smtp server on port 25 I have:

Escape character is '^]'.
220 . SMTP Server (JAMES SMTP Server 3.0-M1) ready Fri, 10 Sep 2010
12:43:45 +0200 (CEST)

I have tried to bind the ip in the smtp component but it's rather a
workaround. Anyway I have a message:
INFO  12:49:06,396 | james.smtpserver | SMTP Service bound to: my_domain
INFO  12:49:06,397 | james.smtpserver | SMTP Service is running on: .

but after connecting to port 25 I have info:
220 . SMTP Server
instead of
220 my_domain SMTP Server


I am able to perform nslookup of my domain and I don't have issue with
this.  I tried to set DNS server directly in dnsservers.xml file, witout
success. 

What's more, While server sturtup I have a message:
INFO  12:49:00,443 | james.domainlist | Local host is: .
INFO  12:49:00,980 | james.domainlist | Local host is: .

The problem causes my mail to be not delivered.
Do you have an idea how to deal with that?





---------------------------------------------------------------------
To unsubscribe, e-mail: server-user-unsubscribe@james.apache.org
For additional commands, e-mail: server-user-help@james.apache.org


Mime
View raw message