james-server-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Norman Maurer <norman.mau...@googlemail.com>
Subject Re: "Working" James Installation Not delivering email
Date Thu, 14 Jan 2010 17:40:42 GMT
Thx for posting your solution.

Enjoy,
Norman

2010/1/14 Alston, Brian (US SSA) <brian.alston@baesystems.com>:
> Norman
>
>    I apologize for not getting back earlier. After playing with the config.xml and
only putting in the fully qualified domain name in the servernames section, the email started
flowing. What the problem ended up being is the <servername>my</servername> line;
it should have actually been <servername>my.hostname</servername> after I put
back all the other servernames and made that correction, all my issues corrected. Thank you
for assisting in troubleshooting this for me.
>
> Have a good day
>
> Brian
>
>
> Brian Alston
> System Administrator
> BAE Systems Technology Solutions & Services
> phone:  (703) 985-3662
> email:  brian.alston@baesystems.com
> ________________________________________
> From: Norman Maurer [norman.maurer@googlemail.com]
> Sent: Thursday, January 07, 2010 5:16 AM
> To: James Users List
> Subject: Re: "Working" James Installation Not delivering email
>
> Just to get sure.. You facing the problem that the email is not
> delivered to the local james mailboxes .. right ?
>
> Are you sure the LocalDelivery mailet is listed "before" the RemoteDelivery ?
>
> Bye,
> Norman
>
> 2010/1/6 Alston, Brian (US SSA) <brian.alston@baesystems.com>:
>> Norman
>>
>>    Thanks for looking at this for me. Here is the <servernames> section of
the config.xml:
>>
>>        <servernames autodetect="true" autodetectIP="true">
>>            <servername>james</servername>
>>            <servername>james.my.hostname</servername>
>>            <servername>mail.my.hostname</servername>
>>            <servername>hostname</servername>
>>            <servername>xxx.xxx.xxx.xxx</servername>
>>        </servernames>
>>
>> Where "xxx.xxx.xxx.xxx" is our external, internet-facing, IP address. Also, the <dnsserver>
section is correct for our network, so I don't believe that can be the issue.
>>
>>
>> Thanks again for your help. Have a great day.
>>
>> Brian
>>
>>
>> Brian Alston
>> System Administrator
>> BAE Systems Technology Solutions & Services
>> phone:  (703) 985-3662
>> email:  brian.alston@baesystems.com
>> ________________________________________
>> From: Norman Maurer [norman.maurer@googlemail.com]
>> Sent: Wednesday, January 06, 2010 1:24 AM
>> To: James Users List
>> Subject: Re: "Working" James Installation Not delivering email
>>
>> Hi Brian,
>>
>> from the james logs it logs like your james server handles
>> emailuser01@my.hostname  as an remote recipient. Could you show us
>> your <servernames> part of the config.xml ?
>>
>> I hope I understand you correct ...
>>
>> Bye,
>> Norman
>>
>>
>> 2010/1/5 Alston, Brian (US SSA) <brian.alston@baesystems.com>:
>>> Hello All
>>>
>>>    I have an environment with many Ubuntu Linux VMs and a couple of Windows
VMs. I have the James 2.3.2 server installed on one of the Linux VMs. On another VM, I have
sendmail installed (for use with Bugzilla). From the sendmail VM I run the command "ls -l
tmp_file.txt | mail emailuser01". When I go back to the james server and tail the mailet-2010-01-04-09-53.log
I get 27 sets of lines that look like this:
>>>
>>> 04/01/10 11:12:31 INFO  James.Mailet: RemoteDelivery: Attempting delivery of
Mail1262621551147-548-to-my.hostname to host james.my.hostname. at 192.168.90.203 for addresses
[emailuser01@my.hostname]
>>> 04/01/10 11:12:31 INFO  James.Mailet: RemoteDelivery: Mail (Mail1262621551147-548-to-my.hostname)
sent successfully to james.my.hostname. at 192.168.90.203 for [emailuser01@my.hostname]
>>>
>>> When I check my email on a Windows server using Outlook, nothing ever shows up.
I get no error on my sendmail server nor on my James server; but, I also never get any mail
delivered to any of my users. I have also looked at the dnsserver, smtpserver, pop3server,
mailstore, remotemanager log files and have found nothing but "INFO" entries and no "ERROR"
entries. When I look at the smtpserver log, I get a single line pair that looks like this:
>>>
>>> 04/01/10 11:23:29 INFO  smtpserver: Connection from sendmailserver.my.host (192.168.90.48)
>>> 04/01/10 11:23:29 INFO  smtpserver: Successfully spooled mail Mail1262622209805-629
from local-admin@sendmailserver.my.host on 192.168.90.48 for [emailuser01@my.host]
>>>
>>>
>>> and I get 27 line pairs that look like this ("local-admin" is our administrator
account on the server):
>>>
>>> 04/01/10 11:23:29 INFO  smtpserver: Successfully spooled mail Mail1262622209805-629
from local-admin@sendmailserver.my.host on 192.168.90.48 for [emailuser01@my.host]
>>> 04/01/10 11:23:29 INFO  smtpserver: Connection from james.my.host (192.168.90.203)
>>>
>>>
>>> When I look at the pop3server log I see a line pair that looks like this:
>>>
>>> 04/01/10 11:27:55 INFO  pop3server: Connection from 192.168.100.99 (192.168.100.99)
>>> 04/01/10 11:27:55 INFO  pop3server: Connection for emailuser01 from 192.168.100.99
(192.168.100.99) closed.
>>>
>>> When I look at the mailstore log file, I see this:
>>>
>>> 04/01/10 11:27:55 INFO  mailstore: Init org.apache.james.mailrepository.filepair.File_Persistent_Stream_Repository
Store
>>> 04/01/10 11:27:55 INFO  mailstore: org.apache.james.mailrepository.filepair.File_Persistent_Stream_Repository
opened in /tools/james-2.3.2/apps/james/var/mail/inboxes/emailuser01
>>> 04/01/10 11:27:55 INFO  mailstore: added repository: file://var/mail/inboxes/emailuser01/STREAM->org.apache.james.mailrepository.filepair.File_Persistent_Stream_Repository
>>> 04/01/10 11:27:55 INFO  mailstore: Init org.apache.james.mailrepository.filepair.File_Persistent_Object_Repository
Store
>>> 04/01/10 11:27:55 INFO  mailstore: org.apache.james.mailrepository.filepair.File_Persistent_Object_Repository
opened in /tools/james-2.3.2/apps/james/var/mail/inboxes/emailuser01
>>> 04/01/10 11:27:55 INFO  mailstore: added repository: file://var/mail/inboxes/emailuser01/OBJECT->org.apache.james.mailrepository.filepair.File_Persistent_Object_Repository
>>> 04/01/10 11:27:55 INFO  mailstore: added repository: file://var/mail/inboxes/emailuser01/MAIL->org.apache.james.mailrepository.AvalonMailRepository
>>>
>>>
>>> So this is what I see every time I send out that test email. It looks like everything
is working except James isn't sending out email to the clients when requested. The pop3 connections
are being logged, but no email gets devivered. Does anybody have any ideas?
>>>
>>> Thank you for taking the time to read. Have a good day.
>>>
>>>
>>> Brian Alston
>>> System Administrator
>>> BAE Systems Technology Solutions & Services
>>> phone:  (703) 985-3662
>>> email:  brian.alston@baesystems.com
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: server-user-unsubscribe@james.apache.org
>>> For additional commands, e-mail: server-user-help@james.apache.org
>>>
>>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: server-user-unsubscribe@james.apache.org
>> For additional commands, e-mail: server-user-help@james.apache.org
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: server-user-unsubscribe@james.apache.org
>> For additional commands, e-mail: server-user-help@james.apache.org
>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: server-user-unsubscribe@james.apache.org
> For additional commands, e-mail: server-user-help@james.apache.org
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: server-user-unsubscribe@james.apache.org
> For additional commands, e-mail: server-user-help@james.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: server-user-unsubscribe@james.apache.org
For additional commands, e-mail: server-user-help@james.apache.org


Mime
View raw message