james-server-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tom Holmes Jr." <thomas.j.hol...@comcast.net>
Subject Re: still ... SMTP issues
Date Fri, 11 Jul 2003 02:47:16 GMT
I am using the account tholmes@tomholmes.net and I am trying to send an
email to my address at 'comcast.net' which is *not* in the <servernames>.
There is no other account setup in Outlook Express.  I even stopped and
restarted the POP3 and SMTP servers to make sure I don't logon the server
from the first machine.   But I am looking at the <servernames> for more
information.

<servernames autodetect="true" autodetectIP="true">
          <servername>localhost</servername>
          <servername>tomholmes.net</servername>
</servernames>

The autodetect I think is what is throwing me.  The first part of the
documentation in the config.xml file says:
If autodetect is TRUE, James wil attempt to discover its own host name AND
use any explicitly specified servernames.
If autodetect is FALSE, James will use only the specified servernames.
So, you can see that my "autodetect" attribute is set to True, and this
should be fine.

The other attribute is True, so the following rules apply.
If autodetectIP is not FALSE, James will also allow add the IP address for
each servername.
The automatic IP detection is to support RFC 2821, Sec 4.1.3, address
literals.

I'm going to try a few combinations and see what I can find.   Thanks.

              Tom

----- Original Message ----- 
From: "Vincenzo Gianferrari Pini" <vincenzo.gianferraripini@praxis.it>
To: "James Users List" <server-user@james.apache.org>
Sent: Wednesday, July 09, 2003 3:33 AM
Subject: RE: still ... SMTP issues


If SMTP AUTH is on, the login is enforced *only* if at least one recipient
address of the message has a domain *not* in the <servernames> entry of
config.xml.

So, for example, if you have a wrong password set and you send in the first
machine a message to a user in a "managed" domain (listed in <servernames>)
SMTP will send the message without problems, while instead if from the
second machine you send a message to a user in a "not managed" domain, the
login will be attempted and fail.

Could it be your case?

FYI, my production James system is running on Windows 2000 server for more
than 250 users, using SMTP AUTH and *not* using <RemoteAddrNotInNetwork>,
because many users are connecting from portables around the world. SMTP AUTH
is working perfectly for me since several months now.

Vincenzo

> -----Original Message-----
> From: Tom Holmes Jr. [mailto:thomas.j.holmes@comcast.net]
> Sent: martedì 8 luglio 2003 14.07
> To: James Users List
> Subject: Re: still ... SMTP issues
>
>
> > Where is the log of the successful SMTP AUTH transaction?
>
> I agree, it is not there, hence the problem!!!!!!!
>
> > 08/07/03 00:23:02 DEBUG smtpserver: Sent: 535 Authentication Failed
> >
> > has received the user and password, verified that neither is null, and
> > failed to match the password against the one in the user repository.
>
> Why?  and how can we fix it.   I know what the  problem is, I've stated it
> all along that it is failing to login in from this second machine.  I will
> provide the log that shows a successful login now from the machine that is
> running James.
>
> ----- Original Message ----- 
> From: "Noel J. Bergman" <noel@devtech.com>
> To: "James Users List" <server-user@james.apache.org>
> Sent: Tuesday, July 08, 2003 2:00 AM
> Subject: RE: still ... SMTP issues
>
>
> > Where is the log of the successful SMTP AUTH transaction?
> >
> > Looking at the code, the code path that produces this:
> >
> > 08/07/03 00:23:02 DEBUG smtpserver: Sent: 535 Authentication Failed
> >
> > has received the user and password, verified that neither is null, and
> > failed to match the password against the one in the user repository.
> >
> > --- Noel
> >
> > -----Original Message-----
> > From: Tom Holmes Jr. [mailto:thomas.j.holmes@comcast.net]
> > Sent: Tuesday, July 08, 2003 0:31
> > To: James Users List
> > Subject: Re: still ... SMTP issues
> >
> >
> > Here is the results of the DEBUG SMTP log:
> >
> > 08/07/03 00:21:19 DEBUG smtpserver: SMTP Service init...
> > 08/07/03 00:21:19 DEBUG smtpserver: SMTP Service ...init end
> > 08/07/03 00:21:19 INFO  smtpserver: SMTP Service started plain:25
> > 08/07/03 00:21:19 DEBUG smtpserver: Using an unbounded pool for SMTP
> > handlers.
> > 08/07/03 00:22:58 DEBUG smtpserver: Retrieving a
> > org.apache.james.smtpserver.SMTPHandler from the pool
> > 08/07/03 00:22:58 DEBUG smtpserver: Getting SMTPHandler from pool.
> > 08/07/03 00:23:02 INFO  smtpserver: Connection from 192.168.1.1
> > (192.168.1.1)
> > 08/07/03 00:23:02 DEBUG smtpserver: Sent: 220 tjh6 SMTP Server
> (JAMES SMTP
> > Server 2.1.3) ready Tue, 8 Jul 2003 00:23:02 -0400 (EDT)
> > 08/07/03 00:23:02 DEBUG smtpserver: Calling start()
> > 08/07/03 00:23:02 DEBUG smtpserver: Watchdog default Worker #18 has time
> to
> > sleep 360000
> > 08/07/03 00:23:02 DEBUG smtpserver: Command received: EHLO tjh7
> > 08/07/03 00:23:02 DEBUG smtpserver: Sent: 250-tjh6 Hello tjh7
> (192.168.1.1
> > [192.168.1.1])
> > 08/07/03 00:23:02 DEBUG smtpserver: Sent: 250-AUTH LOGIN PLAIN
> > 08/07/03 00:23:02 DEBUG smtpserver: Sent: 250 AUTH=LOGIN PLAIN
> > 08/07/03 00:23:02 DEBUG smtpserver: Calling reset() default Worker #18
> > 08/07/03 00:23:02 DEBUG smtpserver: Command received: AUTH LOGIN
> > 08/07/03 00:23:02 DEBUG smtpserver: Sent: 334 VXNlcm5hbWU6
> > 08/07/03 00:23:02 DEBUG smtpserver: Sent: 334 UGFzc3dvcmQ6
> > 08/07/03 00:23:02 ERROR smtpserver: AUTH method LOGIN failed
> > 08/07/03 00:23:02 DEBUG smtpserver: Sent: 535 Authentication Failed
> > 08/07/03 00:23:02 DEBUG smtpserver: Calling reset() default Worker #18
> > 08/07/03 00:23:02 DEBUG smtpserver: Calling stop() default Worker #18
> > 08/07/03 00:23:02 DEBUG smtpserver: Closing socket.
> > 08/07/03 00:23:02 DEBUG smtpserver: Calling disposeWatchdog() default
> Worker
> > #18
> > 08/07/03 00:23:02 DEBUG smtpserver: Watchdog default Worker #18
> is exiting
> > run().
> > 08/07/03 00:23:02 DEBUG smtpserver: Returning SMTPHandler to pool.
> > 08/07/03 00:23:02 DEBUG smtpserver: Returning a
> > org.apache.james.smtpserver.SMTPHandler to the pool
> >
> > Does this help any?  I am using what I thought was the latest stable
> release
> > 2.1.3 ... maybe it is a bug and I need to upgrade?
> >
> > Thanks.
> >                       Tom
> >
> > ----- Original Message -----
> > From: "Noel J. Bergman" <noel@devtech.com>
> > To: "James Users List" <server-user@james.apache.org>
> > Sent: Monday, July 07, 2003 9:03 PM
> > Subject: RE: still ... SMTP issues
> >
> >
> > > > I've been looking for how to turn on the DEBUG option and I
> can't find
> > it.
> > >
> > > SAR-INF/environment.xml.  Change INFO to DEBUG for the SMTP server.
> > >
> > > --- Noel
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: server-user-unsubscribe@james.apache.org
> > > For additional commands, e-mail: server-user-help@james.apache.org
> > >
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: server-user-unsubscribe@james.apache.org
> > For additional commands, e-mail: server-user-help@james.apache.org
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: server-user-unsubscribe@james.apache.org
> > For additional commands, e-mail: server-user-help@james.apache.org
> >
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: server-user-unsubscribe@james.apache.org
> For additional commands, e-mail: server-user-help@james.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: server-user-unsubscribe@james.apache.org
For additional commands, e-mail: server-user-help@james.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: server-user-unsubscribe@james.apache.org
For additional commands, e-mail: server-user-help@james.apache.org


Mime
View raw message