james-mime4j-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmitry Katsubo (JIRA)" <mime4j-...@james.apache.org>
Subject [jira] [Updated] (MIME4J-277) The source is not compatible with Java 1.5
Date Thu, 17 May 2018 21:45:00 GMT

     [ https://issues.apache.org/jira/browse/MIME4J-277?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dmitry Katsubo updated MIME4J-277:
----------------------------------
    Description: 
The root pom tunes the project to use Java 1.5 for both source and target:
{code}
<properties>
    <target.jdk>1.5</target.jdk>
</properties>
...
<plugin>
    <groupId>org.apache.maven.plugins</groupId>
    <artifactId>maven-compiler-plugin</artifactId>
    <configuration>
        <source>${target.jdk}</source>
        <target>${target.jdk}</target>
    </configuration>
</plugin>
{code}
however with such configuration strictly speaking the source is not compatible with the settings,
because {{AbstractMultipart}} implements the interface method {{Multipart.getContentTypeParameters()}}
and is annotated with {{\@Override}}:
{code}
@Override
public List<NameValuePair> getContentTypeParameters() {
    return contentTypeParameters;
}
{code}
The feature to allow {{\@Override}} annotations for implementing methods was added in Java
1.6. Maybe time to upgrade to Java 1.6?


  was:
The root pom tunes the project to use Java 1.5 for both source and target:
{code}
<properties>
    <target.jdk>1.5</target.jdk>
</properties>
...
<plugin>
    <groupId>org.apache.maven.plugins</groupId>
    <artifactId>maven-compiler-plugin</artifactId>
    <configuration>
        <source>${target.jdk}</source>
        <target>${target.jdk}</target>
    </configuration>
</plugin>
{code}
however with such configuration strictly speaking the source is not compatible with the settings,
because {{AbstractMultipart}} implements the interface method {{Multipart.getContentTypeParameters()}}
and is annotated with {{\@Override}}:
{code}
@Override
public List<NameValuePair> getContentTypeParameters() {
    return contentTypeParameters;
}
{code}
The feature to allow {{\@Override}} annotations for implementing methods was added in Java
1.6. Maybe time to upgraded to Java 1.6?



> The source is not compatible with Java 1.5
> ------------------------------------------
>
>                 Key: MIME4J-277
>                 URL: https://issues.apache.org/jira/browse/MIME4J-277
>             Project: James Mime4j
>          Issue Type: Bug
>          Components: project
>    Affects Versions: 0.8.2
>            Reporter: Dmitry Katsubo
>            Priority: Trivial
>
> The root pom tunes the project to use Java 1.5 for both source and target:
> {code}
> <properties>
>     <target.jdk>1.5</target.jdk>
> </properties>
> ...
> <plugin>
>     <groupId>org.apache.maven.plugins</groupId>
>     <artifactId>maven-compiler-plugin</artifactId>
>     <configuration>
>         <source>${target.jdk}</source>
>         <target>${target.jdk}</target>
>     </configuration>
> </plugin>
> {code}
> however with such configuration strictly speaking the source is not compatible with the
settings, because {{AbstractMultipart}} implements the interface method {{Multipart.getContentTypeParameters()}}
and is annotated with {{\@Override}}:
> {code}
> @Override
> public List<NameValuePair> getContentTypeParameters() {
>     return contentTypeParameters;
> }
> {code}
> The feature to allow {{\@Override}} annotations for implementing methods was added in
Java 1.6. Maybe time to upgrade to Java 1.6?



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message