james-mime4j-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ioan Eugen Stan (JIRA)" <mime4j-...@james.apache.org>
Subject [jira] [Commented] (MIME4J-215) Make MboxIterator compatible with target.jdk=1.5
Date Sat, 23 Jun 2012 21:02:42 GMT

    [ https://issues.apache.org/jira/browse/MIME4J-215?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13400060#comment-13400060
] 

Ioan Eugen Stan commented on MIME4J-215:
----------------------------------------

Great. Didn't occur to me why a lot of implementation did not use @Override in James. 
The rest of James moved to 1.6 but mime4j is a low level lib. The compatibility trade-off
is ok with me. 

Thanks Gazda. 
                
> Make MboxIterator compatible with target.jdk=1.5
> ------------------------------------------------
>
>                 Key: MIME4J-215
>                 URL: https://issues.apache.org/jira/browse/MIME4J-215
>             Project: JAMES Mime4j
>          Issue Type: Bug
>            Reporter: Jochen Gazda
>            Assignee: Jochen Gazda
>            Priority: Trivial
>
> Eclipse uses the target.jdk declared in apache-mime4j-project also for its source validation
and produces several error markers for MboxIterator, where methods overriden from Iterable<CharBufferWrapper>
are annotated with @Override.
> There are two possibilities how this can be solved:
> (a) Removing the @Override annotations from the methods in MboxIterator
> (b) Declaring explicit 1.6 source compatibility somewhere in the pom hierarchy.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message