jakarta-watchdog-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jean-Pierre Schnyder" <jean-pierre.schny...@oqibo.com>
Subject Torque: problem obtaining the MapBulder...
Date Wed, 07 Mar 2001 15:12:16 GMT
Hi,

I am using the stand alone version of Torque and am trying to make it work.
I did generate the om classes for a Oracle target. I get an exception when
trying to do a ...Peer.doSelect(Criteria). Here's the stack trace:

java.lang.ExceptionInInitializerError:
org.apache.turbine.services.InstantiationException: ServiceBroker: unknown
service TurbineLoggingService requested
	at
org.apache.turbine.services.BaseServiceBroker.getServiceInstance(BaseService
Broker.java:311)
	at
org.apache.turbine.services.BaseServiceBroker.getService(BaseServiceBroker.j
ava:256)
	at org.apache.turbine.util.Log.error(Log.java:455)
	at org.apache.turbine.om.peer.BasePeer.getMapBuilder(BasePeer.java:1824)
	at
com.oqibo.testtorque.dat.om.BaseClientPeer.<clinit>(BaseClientPeer.java:32)
	at com.oqibo.testtorque.svc.Test.doSelectAll(Test.java:32)
	at com.oqibo.testtorque.svc.Test.main(Test.java:50)

the problem is that the public static MapBuilder getMapBuilder(String p0)
method in the BasePeer class has an empty body and is not implemented in the
child peer classes. This seem to be a bug, or am I doing something wrong ?

Thanks for the answer,

Jean-Pierre
----------------------------------------------------------------------------
oqibo.com finance SA
Jean-Pierre Schnyder   Senior Software Architect   Voice  : +41 21 693.85.00
Science Park (BP)                                  Fax    : +41 21 693.85.01
Swiss Federal Institute of Technology              Site   : www.oqibo.com
1015 Lausanne - Switzerland                        E-mail :
jean-pierre.schnyder@oqibo.com
----------------------------------------------------------------------------




Mime
View raw message