jakarta-watchdog-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Craig R. McClanahan" <Craig.McClana...@eng.sun.com>
Subject Re: OK, What Gives?
Date Fri, 01 Dec 2000 00:17:58 GMT
"Santosh Singh [TEMP]" wrote:

> Craig,
>  Does it haang or it takes a long time ...?
>    Now if you use the option all , both servelets and jsp tests are run plus jsp
> tests are run in two different modes (jsp and XML) . before it starts running
> the tests the XML view of all the jsp files in the workspace is generated which
> takes considerable time.I'll suggest you running the tests one by one just to
> see that tests are actually running.Here are the options for that
>    jsp (jsp tests with jsp pages)
>    jsp-xml (jsp tests with xml pages)
>    jsp-all (jsp tests with both jsp and xml pages one by one)
>    gtestservlet (servlet tests)
>    all (all the above tests)
>

It appeared to hang (left it there for quite a few minutes; no discernable CPU or
disk activity).

Same thing happened when I tried just the "jsp" tests -- which happen to the the
first ones tried on an "all" target as well.

>
> Hope this helps....
> Thanks,
> Santosh
>

Craig


>
> > Mailing-List: contact watchdog-dev-help@jakarta.apache.org; run by ezmlm
> > list-help: <mailto:watchdog-dev-help@jakarta.apache.org>
> > list-unsubscribe: <mailto:watchdog-dev-unsubscribe@jakarta.apache.org>
> > list-post: <mailto:watchdog-dev@jakarta.apache.org>
> > Delivered-To: mailing list watchdog-dev@jakarta.apache.org
> > X-Accept-Language: en
> > MIME-Version: 1.0
> > To: watchdog-dev@jakarta.apache.org
> > Subject: OK, What Gives?
> > Content-Transfer-Encoding: 7bit
> > X-Spam-Rating: locus.apache.org 1.6.2 0/1000/N
> >
> > I'm trying to get the "jakarta-watchdog-4.0" tests to run against Tomcat 4.0,
> > and am not having much luck.  I did a "./build.sh dist" build of Watchdog,
> > copied the WAR files to Tomcat's webapps directory, and started Tomcat.  Then
> I
> > did
> >
> >     cd <<jakarta-home>>/dist/watchdog/bin
> >     ./watchdog.sh all
> >
> > and get the following output:
> >
> >     Guessing WATCHDOG_HOME from watchdog.sh to ./..
> >     Setting WATCHDOG_HOME to ./..
> >     Using classpath:
> >
> ./../lib/client.jar:./../lib/testdriver.jar:./../lib/moo.jar:./../lib/ant.jar:./
> usr/locall/jdk1.2.2/lib/tools.jar:/usr/local/jdk1.2.2/lib/classes.zip
> >
> >     Buildfile: ./../conf/jsp-gtest.xml
> >
> >     jsp-test:
> >
> > and it just hangs.  Running netstat shows that there is an established TCP
> > connection on port 8080, so apparently the client has actually contacted the
> > server, but there's no output at all.
> >
> > Any theories on what is going on?
> >
> > Craig McClanahan
> >
> >


Mime
View raw message