jakarta-watchdog-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Santosh Singh [TEMP]" <Santosh.Si...@eng.sun.com>
Subject Re: May I ask a question of Tomcat?
Date Tue, 31 Oct 2000 17:40:46 GMT
Hi,
 This is the correct behaviour.You are pointing to a URL relative to the 
root.Why do you think that the correct URL should be the one you mentioned?
 
 -Santosh
 
> Mailing-List: contact watchdog-dev-help@jakarta.apache.org; run by ezmlm
> list-help: <mailto:watchdog-dev-help@jakarta.apache.org>
> list-unsubscribe: <mailto:watchdog-dev-unsubscribe@jakarta.apache.org>
> list-post: <mailto:watchdog-dev@jakarta.apache.org>
> Delivered-To: mailing list watchdog-dev@jakarta.apache.org
> Delivered-To: moderator for watchdog-dev@jakarta.apache.org
> To: <watchdog-dev@jakarta.apache.org>
> Subject: May I ask a question of Tomcat?
> MIME-Version: 1.0
> X-Priority: 3
> X-MSMail-Priority: Normal
> X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2615.200
> X-Spam-Rating: locus.apache.org 1.6.2 0/1000/N
> 
> Hi,
> 
> I was installing Tomcat and Apache for testing. Most of functions were working 
fine.
> But there was a problem when I want to upload  a file. A form tag was setting 
in a jsp file as following
> <form enctype="multipart/form-data" action="/servlet/UploadDepartmentImage" 
method=POST>
> when I submit to upload, the URL was transfered to
> http://servername/servlet/UploadDepartmentImage , this is a worng URL
> Actually, the correct URL should be 
> http://servername/jeestore/servlet/jeestore/UploadDepartmentImage
> 
> And, web.xml was setting as following
> 
> <web-app>
>     <servlet>
>         <servlet-name>jeestore</servlet-name>
>         <servlet-class>com.jeestore.JeestoreServlet</servlet-class>
>            <init-param>
>              <param-name>servlet.properties.location</param-name>
>              <param-value>/home/jeestore/etc/jeestore.properties</param-value>
>            </init-param>
>         <load-on-startup>1</load-on-startup>
>     </servlet>
>     <servlet>
>         <servlet-name>UploadLogo</servlet-name>
>                 <servlet-class>com.oreilly.servlet.UploadLogo</servlet-class>
>                 <load-on-startup>2</load-on-startup>
>     </servlet>
>     <servlet>
>         <servlet-name>UploadProductImage</servlet-name>
>                 
<servlet-class>com.oreilly.servlet.UploadProductImage</servlet-class>
>                 <load-on-startup>3</load-on-startup>
>     </servlet>
>     <servlet>
>         <servlet-name>UploadDepartmentImage</servlet-name>
>                 
<servlet-class>com.oreilly.servlet.UploadDepartmentImage</servlet-class>
>                 <load-on-startup>4</load-on-startup>
>     </servlet>
> </web-app>
>  
> Would you please tell me what's wrong? 
> Thanks.
>  
> Baron
> 


Mime
View raw message