jakarta-watchdog-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rousseau, John" <JRouss...@silverstream.com>
Subject Problems with servlet tests under 1.3.0
Date Tue, 22 Aug 2000 20:41:55 GMT
I've been working with the Watchdog servlet tests here for a
while. I've been running them under JDK1.2.2-004 on NT.

This week I moved the client environment that the tests are using
from 1.2.2 to 1.3.0 and 5 tests started FAILing (going back to 1.2.2
makes them work again). Running our server environment under 1.2.2
or 1.3.0 does not change the test performance.

For example, the
javax_servlet.ServletRequest.GetCharacterEncodingTest test, when run
stand-alone passes. When this test is run after
javax_servlet.ServletRequest.GetAttributeNamesTest, it fails. The
"Content-Type:" header is not included on the request.

Also, we are seeing strange behavior with the "Connection:"
header. Client tests that are not at the end of a test run have the
"Connection: keep-alive" header, yet it appears that the client is
closing the connection after each test.

Have others here been able to run these tests on 1.3.0 successfully?

Can someone at Sun provide some detail on the HttpURLConnection /
URLConnection changes made in 1.3.0?

Thanks for any help!
-John

----------------------------------------------------------------
John Rousseau                               jrr@silverstream.com
SilverStream Software                     Phone: +1 978 262 3564
2 Federal Street                            Fax: +1 978 262 3499
Billerica, MA 01821                  http://www.silverstream.com
----------------------------------------------------------------

Mime
View raw message