jakarta-jcs-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aaron Smuts <asm...@yahoo.com>
Subject Re: Remove dependency for concurrent.jar
Date Thu, 27 Aug 2009 13:33:58 GMT
JCS is compatible with JDK 1.4  Until recently, it could run on 1.3.  There was no good backport
1.3.  There is a good backport for 1.4.  The changes would not be very extensive.  

Things that have to change:

thread pool manager
remote cache server
the lateral listeners
and a few other tiny places

I've been meaning to do this, but I can't do it for a couple of weeks. Patches are welcome.

Aaron

--- On Thu, 8/27/09, Nuno Sénica <nsenica@gmail.com> wrote:

> From: Nuno Sénica <nsenica@gmail.com>
> Subject: Remove dependency for concurrent.jar
> To: jcs-users@jakarta.apache.org
> Date: Thursday, August 27, 2009, 4:02 AM
> Hi all,
> 
> At the company where I work for, we have an application
> which relies on JCS
> and it has proven to be a good solution so far. But now, we
> were informed
> about legal issues by using concurrent lib and we are being
> instructed to
> change the caching lib.
> 
> My question is if there's any plan to use the native
> concurrent instead of
> the lib that JSC depend on at the moment ? Is so, when it
> is planned to be
> available ?
> 
> Thanks in advance.
> 
> Regards,
> Nuno
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: jcs-users-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jcs-users-help@jakarta.apache.org


Mime
View raw message