jakarta-jcs-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Rasmussen <rasmus...@2e-systems.com>
Subject RE: Remote Auxiliary Cache
Date Mon, 11 Jul 2005 15:00:16 GMT
My remote.cache.ccf, which is included in the classpath
looks like this:

registry.host=localhost
registry.port=1099

remote.cache.service.port=1099
remote.cluster.LocalClusterConsistency=true


Did I put this file in the wrong place ?

Tom


On Mon, 2005-07-11 at 08:36 -0500, Smuts, Aaron wrote:
> 
> What does your remote cache config file look like?
> 
> You have to startup the remote server, which uses a slightly different
> config file.  Did you do this?
> 
> 
> Aaron
> 
> > -----Original Message-----
> > From: Thomas Rasmussen [mailto:rasmussen@2e-systems.com]
> > Sent: Monday, July 11, 2005 6:16 AM
> > To: JCS Users List
> > Subject: Remote Auxiliary Cache
> > 
> > Hi,
> > 
> > I have an application that is running
> > fine using a local cache.
> > I've tried to configure it to use a
> > remote auxiliary cache having add the
> > following section to my cache.ccf:
> > 
> > 
> > ## REMOTE RMI CACHE WITHOUT FAILOVER
> > 
> >
> jcs.auxiliary.RCache=org.apache.jcs.auxiliary.remote.RemoteCacheFactory
> >
> jcs.auxiliary.RCache.attributes=org.apache.jcs.auxiliary.remote.RemoteCa
> ch
> > eAttributes
> > jcs.auxiliary.RCache.attributes.RemoteTypeName=LOCAL
> > jcs.auxiliary.RCache.attributes.RemoteHost=localhost
> > jcs.auxiliary.RCache.attributes.RemotePort=1099
> > jcs.auxiliary.RCache.attributes.GetOnly=true
> > 
> > 
> > 
> > The rest of my cache.ccf looks like this:
> > 
> > 
> > 
> > #### DEFAULT CACHE REGION
> > 
> > jcs.default=DC,RCache
> >
> jcs.default.cacheattributes=org.apache.jcs.engine.CompositeCacheAttribut
> es
> > JCS.default.cacheattributes.MaxObjects=1200
> >
> jcs.default.cacheattributes.MemoryCacheName=org.apache.jcs.engine.memory
> .l
> > ru.LRUMemoryCache
> > jcs.default.cacheattributes.maxMemoryIdleTimeSeconds=3600
> > jcs.default.elementattributes=org.apache.jcs.engine.ElementAttributes
> > jcs.default.elementattributes.IsEternal=false
> > jcs.default.elementattributes.maxLifeSeconds=3600
> > jcs.default.elementattributes.IdleTime=1800
> > jcs.default.elementattributes.IsSpool=true
> > jcs.default.elementattributes.IsLateral=false
> > jcs.default.elementattributes.IsRemote=true
> > 
> > 
> > 
> > #### PREDEFINED CACHE REGIONS
> > 
> > jcs.region.testCache1=DC,RCache
> >
> jcs.region.testCache1.cacheattributes=org.apache.jcs.engine.CompositeCac
> he
> > Attributes
> > jcs.region.testCache1.cacheattributes.MaxObjects=1200
> >
> jcs.region.testCache1.cacheattributes.MemoryCacheName=org.apache.jcs.eng
> in
> > e.memory.lru.LRUMemoryCache
> > jcs.region.testCache1.cacheattributes.maxMemoryIdleTimeSeconds=7200
> >
> jcs.region.testCache1.elementattributes=org.apache.jcs.engine.ElementAtt
> ri
> > butes
> > jcs.region.testCache1.elementattributes.IdleTime=1800
> > jcs.region.testCache1.elementattributes.IsEternal=false
> > jcs.region.testCache1.elementattributes.IsSpool=true
> > jcs.region.testCache1.elementattributes.IsLateral=false
> > jcs.region.testCache1.elementattributes.IsRemote=true
> > 
> > 
> > 
> > #### AVAILABLE AUXILIARY CACHES
> > # Primary disk cache
> > 
> >
> jcs.auxiliary.DC=org.apache.jcs.auxiliary.disk.indexed.IndexedDiskCacheF
> ac
> > tory
> >
> jcs.auxiliary.DC.attributes=org.apache.jcs.auxiliary.disk.indexed.Indexe
> dD
> > iskCacheAttributes
> > jcs.auxiliary.DC.attributes.DiskPath=/tmp/jcs/raf
> > jcs.auxiliary.DC.attributes.MaxPurgatorySize=10000
> > jcs.auxiliary.DC.attributes.MaxKeySize=10000
> > jcs.auxiliary.DC.attributes.OptimizeAtRemoveCount=300000
> > jcs.auxiliary.DC.attributes.MaxRecycleBinSize=7500
> > 
> > 
> > When trying to run this after having started the rmiregistry,
> > I get the following error messages:
> > 
> > 
> > "ERROR  - Problem finding server at
> >
> [//localhost:1099/org.apache.jcs.auxiliary.remote.behavior.IRemoteCacheS
> er
> > vice]"
> > 
> > 
> > Furthermore I get the following stack trace (upper part):
> > 
> > 
> > "java.rmi.NotBoundException:
> > org.apache.jcs.auxiliary.remote.behavior.IRemoteCacheService
> >         at
> > sun.rmi.transport.StreamRemoteCall.exceptionReceivedFromServer
> > (StreamRemoteCall.java:247)
> >         at sun.rmi.transport.StreamRemoteCall.executeCall
> > (StreamRemoteCall.java:223)
> >         at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:343)
> >         at sun.rmi.registry.RegistryImpl_Stub.lookup(Unknown Source)
> >         at java.rmi.Naming.lookup(Naming.java:84)"
> > 
> > 
> > I've tested the port 1099 after having issued the rmiregistry
> > command and it is open.
> > 
> > 
> > What have I misunderstood/screwed up ?
> > 
> > 
> > Tom
> > 
> > 
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: jcs-users-unsubscribe@jakarta.apache.org
> > For additional commands, e-mail: jcs-users-help@jakarta.apache.org
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: jcs-users-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: jcs-users-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: jcs-users-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jcs-users-help@jakarta.apache.org


Mime
View raw message