jakarta-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From vijayaratha vijayasingam <vijayara...@yahoo.co.uk>
Subject Re: [BSF] Couldn't build bsf project from source
Date Wed, 27 Apr 2011 11:00:45 GMT





________________________________
From: sebb <sebbaz@gmail.com>
To: dev@jakarta.apache.org
Sent: Wed, 27 April, 2011 16:21:18
Subject: Re: [BSF] Couldn't build bsf project from source

On 27 April 2011 11:22, vijayaratha vijayasingam
<vijayaratha@yahoo.co.uk> wrote:
> Hi all,
> I'm trying to build the bsf project from source (version  3.0.0) .I downloaded
> the source distribution and tried  to build it.. but  anyway  i'm failing 
 with
> the following issue [1], since 'jsr' site is  unavailable..

Not a lot we can do to fix that; it's not an ASF resource.

> Would be great if someone look into this issue ASAP.. i'm trying to debug my
> project,  for that i need the bsf source..

Which is available from the download location as usual.

The engines are only needed to test some parts of BSF; just comment
out the following lines in the top level pom:

        <module>bsf-engines</module>
and
        <module>testing</module>

Hi, 
Thanks for the response ,
 i tried to avoid testing/bsf-engines modules..but distribution needs 
bsf-engines jar..so couldn't build the project...:(

Thanks
-Ratha.

Note that BSF 3.0 is generally only needed for projects running on
Java 1.4 and Java 1.5 as Java 1.6+ contains the JSR-223 API.
There are a few utility methods in the bsf-utils jar that may be
useful with Java 1.6.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: dev-help@jakarta.apache.org
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message