jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Srinivasan, Radha" <Radha_Sriniva...@stercomm.com>
Subject RE: How to run Cactus tests on already running Weblogic server?
Date Wed, 15 Jul 2009 09:41:56 GMT
Never mind Cargo automatically does that. If a Weblogic instance is
running it does not try to start the server. We don't have to use
<runservertests> task anymore.

<cactus warfile="${src.war.dir}/mytest.war" fork="yes"
        errorProperty="test.failed"
        failureproperty="tests.failed" printsummary="yes">
	<containerset >
      <cargo containerId="weblogic9x"
             home="${bea.home}/weblogic92"
	     output="${testresults.dir}/weblogic-output.log"
log="${testresults.dir}/weblogic-cargo.log"
			 type="installed" >
          <configuration>
             <property name="cargo.servlet.port" value="${port}"/>
              <property name="cargo.logging" value="high"/>
			  <property name="cargo.jvmargs"
value="-Dvendor=shell
-DvendorFile=${install.dir}/properties/servers.properties
			  -Xdebug -Xnoagent"/>
              <property name="cactus.toDir" value="${testresults.dir}"/>
              <deployable type="war" file="${src.war.dir}/stktest.war"/>
          </configuration>
      </cargo>
	</containerset>
	<classpath refid="test.classpath"/>
	<formatter type="brief" usefile="false"/>
	<formatter type="xml" />
	<test name = "${testcase.name}"/>
	<sysproperty key="test.server.baseurl"
value="http://${server}:${port}"/>
</cactus>

<junitreport todir="${reports.dir}">
  <fileset dir="${testresults.dir}" includes="TEST-*.xml"/>
     <report todir="${reports.dir}" format="frames"/>
</junitreport>
<fail message="Tests failed. Please see test reports"
      if="test.failed" />
</target>


-----Original Message-----
From: Srinivasan, Radha [mailto:Radha_Srinivasan@stercomm.com] 
Sent: Wednesday, July 15, 2009 12:47 PM
To: cactus-user@jakarta.apache.org
Subject: How to run Cactus tests on already running Weblogic server? 

 

Hi,

I am trying to use <runservertests> since I could not do it with cargo.

I have started the server with test war deployed

This is what I have in the xml

 

<runservertasks
testurl="http://${server}:${port}/<webapp>/ServerRedirector/Cactus_Servi
ce=RUN_TEST" starttarget="start.weblogic.92"
stoptarget="stop.weblogic.92" testtarget="test"/>

 

--> starttarget and stoptarget are empty targets.

 

Thanks

Radha Srinivasan

 


---------------------------------------------------------------------
To unsubscribe, e-mail: cactus-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: cactus-user-help@jakarta.apache.org


Mime
View raw message