jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kazuhito SUGURI <suguri.kazuh...@lab.ntt.co.jp>
Subject Re: FormAuthentication problem
Date Wed, 30 Apr 2008 06:30:51 GMT
Hi Eric,

In article <266b3cb30804291528s13dafae0y16425435e3dd1a1c@mail.gmail.com>,
Tue, 29 Apr 2008 15:28:56 -0700,
"Eric Barendt" <eric@danube.com> wrote: 
eric> I'm working on switching our application from Basic to Form authentication.
[snip]
eric> With FormAuthentication, I get  "Missing service name parameter
eric> [Cactus_Service] in HTTP request." and "Error getting test result. This
eric> could happen for example if you're using a load-balancer."  This is what I
eric> see in my access log:
eric> 
eric> 127.0.0.1 - - [29/Apr/2008:16:50:18 -0500] "GET
eric> /application/ServletRedirectorSecure HTTP/1.1" 200 2357
eric> 127.0.0.1 - - [29/Apr/2008:16:50:18 -0500] "POST
eric> /application/j_security_check HTTP/1.1" 302 -
eric> 127.0.0.1 - user [29/Apr/2008:16:50:18 -0500] "GET
eric> /application/ServletRedirectorSecure HTTP/1.1" 500 2527
eric> 127.0.0.1 - user [29/Apr/2008:16:50:18 -0500] "GET
eric> /application/ServletRedirectorSecure?Cactus_Service=GET_RESULTS HTTP/1.1"
eric> 500 2556

What is your servlet container?

If you are using Tomcat later than 5.5.20,
my post to tomcat-users ML might helps you:
	http://marc.info/?l=tomcat-user&m=119098089904045&w=2

If it works for you, please let me know.
----
Kazuhito SUGURI

Mime
View raw message