jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kazuhito SUGURI <suguri.kazuh...@lab.ntt.co.jp>
Subject Re: Could not run junit test class in eclipse
Date Wed, 01 Aug 2007 08:15:48 GMT
Hi,

In article <885205.13102.qm@web7610.mail.in.yahoo.com>,
Wed, 1 Aug 2007 08:32:52 +0100 (BST),
jeya seelan <rnjeyaseelan@yahoo.co.in> wrote: 
rnjeyaseelan> this is seelan. i follow the folder structure what is given in the cactus
document.
rnjeyaseelan> i am using eclipse3.1 IDE and JBOSS server.
rnjeyaseelan> i created struts framework application war file and put it
rnjeyaseelan> in the deploy folder of jboss.
rnjeyaseelan> if i run jboss server i can access application and work on that.
rnjeyaseelan> after running my sample struts application, i run the cactus
rnjeyaseelan> test class. (Right click on the cactus java class file and
rnjeyaseelan> i click run as JUnit Test). but it throws exception. that is
rnjeyaseelan> "org.apache.cactus.util.ChainedRuntimeException: Missing Cactus property
rnjeyaseelan> [cactus.contextURL]".

You have to configure the client-side of Cactus properly.
The cactus.properties should exist in the class-path of which
the JVM of the test-runner would search for.

Although I cannot point out exact way to set it up with Eclipse
(because I'm not an Eclipse user), following pages may give you
information for the configuration:
	http://jakarta.apache.org/cactus/how_it_works.html
	http://jakarta.apache.org/cactus/integration/manual/howto_classpath.html

Hope this helps.
----
Kazuhito SUGURI

Mime
View raw message