jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fabio Rossi <paranoid_fa...@yahoo.it>
Subject URGENT please help!!
Date Tue, 12 Jun 2007 18:03:01 GMT
Hi, i'm using Cactus. I wrote some tests and everything worked fine until today.
When i try to run the tests, the first test run without any problem (even if i rerun it),
but if i try to run other tests i get:

Error finding class [AbilitationServletTest] using both the Context classloader and the webapp
classloader. Possible causes include:  - Your webapp does not include your test classes, 
- The cactus.jar is not located in your WEB-INF/lib directory and your Container has not set
the Context classloader to point to the webapp one" type="org.apache.cactus.internal.client.ServletExceptionWrapper">

The absurd thing is that if restart tomcat, run AbilitationServletTest for first, it works
fine. But if i run the other tests i get the same exception!!! and the same thing with all
tests (the first run fine, whatever it is, the others don't run until i restart tomcat!!!).
I tried unistalling and reinstalling Tomcat but nothing...

It's like ServletTestRunner doesn't refresh somehow!! For example, i run a servlet (not a
test, but only a servlet) at a path

http://localhost:8080/ServletX/....

And then, i tried to run a test for another servlet at the path:

http://localhost:8080/HtmlTest/ServletTestRunner?suite=.....

And I got an exception saying that cactus cannot get the test result from

http://localhost:8080/ServletX/ServletTestRunner?suite=.....

It's crazy, it's like it mixed two different paths.

Please  help me!! i'm going mad 
 	      
---------------------------------

---------------------------------
L'email della prossima generazione? Puoi averla con la nuova Yahoo! Mail
Mime
  • Unnamed multipart/alternative (inline, 8-Bit, 0 bytes)
View raw message