jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From piampri <piam...@yahoo.com>
Subject Getting error: javax.servlet.ServletException: Failed to load test suite [TestSampleServlet], Reason is [Class not found "TestSampleServlet"]
Date Wed, 21 Feb 2007 21:03:54 GMT

Hi, 

I'm a new user to Cactus and I'm getting a strange error on trying to launch
TestRunner with the Weblogic container. My server classpath contains all of
the relevant jars namely:

cactus.jar 
commons-httpclient.jar 
commons-logging.jar 
junit.jar 
aspectjrt.jar 

in addition to my classes under test and the classes which contain the test
(ie. which extend TestCase). 

However the following error stack indicates a problem finding my test class:

Reason is [Class not found "TestSampleServlet"]
	at
org.apache.cactus.server.runner.ServletTestRunner.run(ServletTestRunner.java:302)
	at
org.apache.cactus.server.runner.ServletTestRunner.doGet_aroundBody0(ServletTestRunner.java:186)
	at
org.apache.cactus.server.runner.ServletTestRunner.doGet_aroundBody1$advice(ServletTestRunner.java:224)
	at
org.apache.cactus.server.runner.ServletTestRunner.doGet(ServletTestRunner.java)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:740)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
	at
weblogic.servlet.internal.ServletStubImpl$ServletInvocationAction.run(ServletStubImpl.java:1006)
	at
weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:419)
	at
weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:315)
	at
weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(WebAppServletContext.java:6718)
	at
weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
	at
weblogic.security.service.SecurityManager.runAs(SecurityManager.java:121)
	at
weblogic.servlet.internal.WebAppServletContext.invokeServlet(WebAppServletContext.java:3764)
	at
weblogic.servlet.internal.ServletRequestImpl.execute(ServletRequestImpl.java:2644)
	at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:219)
	at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:178)

I've tried jarring the classes separately and then adding the jar to the war
file instead of as individual classes. However the original error still
occurs. Can someone help with this. 

I am using the Weblogic 8.1 application server.


-- 
View this message in context: http://www.nabble.com/Getting-error%3A-javax.servlet.ServletException%3A-Failed-to-load-test-suite--TestSampleServlet-%2C-Reason-is--Class-not-found-%22TestSampleServlet%22--tf3269274.html#a9089128
Sent from the Cactus - User mailing list archive at Nabble.com.


Mime
View raw message