jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kazuhito SUGURI <suguri.kazuh...@lab.ntt.co.jp>
Subject Re: problem getting test results
Date Mon, 27 Feb 2006 05:41:50 GMT
Hi Paulo,

In article <20060224123400.54426.qmail@web52114.mail.yahoo.com>,
Fri, 24 Feb 2006 12:34:00 +0000 (GMT),
Paulo R C Siqueira <gangrelbr1@yahoo.com.br> wrote: 
gangrelbr1> Since I don't know how exactly NetBeans handle the tests
gangrelbr1> internally, and I'm using the default configurations for JBoss,
gangrelbr1> it seens more likely that (2) is what is happening.
gangrelbr1> What should I do?

You might try run test without NetBeans to know whether Cactus works
with your target container (JBoss-4.0.3).
I had tried following steps last weekend and it worked fine:
(1) create cactified-war with a simple test
(2) start JBoss
(3) deploy the cactified-war file to JBoss manually
(4) run test by using junit.textui.TestRunner:
	java junit.textui.TestRunner <test class name>

My environment is as follows:
	Linux kernel 2.6.8
	Sun jdk 1.5.0_06
	JBoss-4.0.3SP1
	Cactus-1.7.1

Once you found a working configuration, you can use that for other tests,
and can narrow the problem you have encountered.

Regards,
----
Kazuhito SUGURI

Mime
View raw message