jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kazuhito SUGURI <suguri.kazuh...@lab.ntt.co.jp>
Subject Re: Failed to get the test results at [http://localhost:80/test/ServletRedirector]
Date Tue, 27 Dec 2005 05:08:41 GMT
Hi Senthil,

Have you solved the problem?
If the problem is still there, let us start from a working sample.

In article <20051220194447.15165.qmail@web51814.mail.yahoo.com>,
Tue, 20 Dec 2005 11:44:47 -0800 (PST),
senthil kumar <senthil_cbe@yahoo.com> wrote: 
senthil_cbe> Thanks for your reply. I set the break point in my
senthil_cbe> beginXXX and Test Suite() methods it looks like
senthil_cbe> beginXXX is not at all called. It gets into suite()
senthil_cbe> method but not beginXX method. Here is my begin method

After some tries, I cannot reproduce your problem.

Appending are codes I tried:
	SampleJUnitTest.java   - extends JUnit's TestCase
	SampleServletTest.java - extends Cactus's ServletTestCase
	AllTests.java          - provide a suite()
	web.xml
	tomcat-users.xml

A war-archive should have structure as follows:
	./WEB-INF/lib
	./WEB-INF/lib/cactus-1.7.1.jar
	./WEB-INF/lib/commons-httpclient-2.0.2.jar
	./WEB-INF/lib/aspectjrt-1.2.1.jar
	./WEB-INF/lib/junit.jar
	./WEB-INF/lib/commons-logging-1.0.4.jar
	./WEB-INF/classes
	./WEB-INF/classes/SampleServletTest.class
	./WEB-INF/classes/SampleJUnitTest.class
	./WEB-INF/classes/AllTests.class
	./WEB-INF/web.xml

I deployed the war-archive (sample.war) ant tomcat-users.xml
to the Tomcat-5.5.9 on my localhost. All of following URLs work fine:
      http://localhost:8080/sample/ServletTestRunner?suite=AllTests
      http://localhost:8080/sample/ServletTestRunner?suite=SampleJUnitTest
      http://localhost:8080/sample/ServletTestRunner?suite=SampleServletTest

Could you explain what I should do to reproduce your problem form the sample?

Regards,
----
Kazuhito SUGURI

Mime
View raw message