jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paolo Castagna <paolo.casta...@hp.com>
Subject Problem with <cactus> task using Cactus v1.7 + Tomcat 5.5.9 + JDK v1.5.0_04 ...
Date Mon, 04 Jul 2005 11:06:18 GMT
Hi,
I am using Cactus v1.7 with JDK v1.5.0_04 and Tomcat v5.5.9,
but when I run tests using the <cactus> Ant task it does not
start Tomcat:

-----------------------------------------------------------------------
Output redirected to /home/castagna/workspace/mywebapp/build/test-
reports/tomcat5x.out
Execute:Java13CommandLauncher: Executing '/opt/jdk1.5.0_04/jre/bin/java'
with arguments:
'-Dlog4j.appender.cactus=org.apache.log4j.FileAppender'
'-Djava.util.logging.FileHandler.pattern=build/test_server.log'
'-Dlog4j.additivity.org.apache.commons.httpclient=false'
'-Dlog4j.additivity.httpclient=false'
'-Dorg.apache.commons.logging.simplelog.log.org.apache.cactus=trace'
'-Dlog4j.appender.cactus.layout=org.apache.log4j.PatternLayout'
'-
Djava.util.logging.FileHandler.formatter=java.util.logging.SimpleFormatter
'
'-Dlog4j.configuration=file:build/logging_server.properties'
'-Dorg.apache.cactus.level=ALL'
'-
Dorg.apache.commons.logging.simplelog.log.org.apache.commons.httpclient=tr
ace'
'-Dhandlers=java.util.logging.FileHandler'
'-Dlog4j.appender.cactus.File=build/test_server.log'
'-Dorg.apache.commons.logging.simplelog.showlogname=true'
'-Djava.util.logging.config.file=build/logging_server.properties'
'-Dlog4j.category.httpclient=WARN, cactus'
'-Dlog4j.appender.cactus.Append=false'
'-Dlog4j.category.org.apache.commons.httpclient=DEBUG, cactus'
'-Dlog4j.category.org.apache.cactus=DEBUG, cactus'
'-Dlog4j.rootCategory=DEBUG, cactus'
'-Dlog4j.additivity.org.apache.cactus=false'
'-Dlog4j.appender.cactus.layout.ConversionPattern=%d{ABSOLUTE} [%t] %-5p
%-30.30c{2} %x - %m %n'
'-Dcactus.contextURL=http://localhost:8080/mywebapp-
cactus'
'-Dcatalina.home=/opt/jakarta-tomcat-5.5.9'
'-Dcatalina.base=/tmp/cactus/tomcat5x'
'-classpath'
'/opt/jakarta-
tomcat-5.5.9/bin/bootstrap.jar:/opt/jdk1.5.0_04/lib/tools.jar'
'org.apache.catalina.startup.Bootstrap'
'start'

The ' characters around the executable and arguments are
not part of the command.
Checking if server is up ...
Failed to connect to [http://localhost:8080/mywebapp-
cactus/ServletRedirector?Cactus_Service=RUN_TEST] (Connection refused)
Checking if server is up ...
Failed to connect to [http://localhost:8080/mywebapp-
cactus/ServletRedirector?Cactus_Service=RUN_TEST] (Connection refused)
Checking if server is up ...
Failed to connect to [http://localhost:8080/mywebapp-
cactus/ServletRedirector?Cactus_Service=RUN_TEST] (Connection refused)
Checking if server is up ...
Failed to connect to [http://localhost:8080/mywebapp-
cactus/ServletRedirector?Cactus_Service=RUN_TEST] (Connection refused)
Checking if server is up ...
Failed to connect to [http://localhost:8080/mywebapp-
cactus/ServletRedirector?Cactus_Service=RUN_TEST] (Connection refused)
Checking if server is up ...
-----------------------------------------------------------------------

I do not have any problem using Tomcat v4.x or Tomcat v5.0.x with JDK
v1.5.0_04. 

Best regards,
Paolo Castagna.


Mime
View raw message