jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guillaume Lederrey <Gehel-Li...@ledcom.ch>
Subject Re: Missing service name parameter [Cactus_Service] in HTTP request
Date Wed, 23 Mar 2005 09:06:39 GMT
  I still didnt resolve my problems, so I'll try to clarify the situation and 
maybe sombody knows that stuff better than me :

  I tested my test by running them with authentication disabled, both by 
directing them to the standard "ServletRedirector" and to 
"ServletRedirectorSecure" (note that in this case, ServletRedirectorSecure 
was not password protected). Everything went fine.

  Then I added :

webRequest.setAuthentication(new FormAuthentication("admin", "admin"));

  to the "begin" method (still without password protection), and the test 
fails. The logs show  "Missing service name parameter [Cactus_Service] in 
HTTP request. Received query string is []".

  If I do the same, but using a BasicAuthenticator (still no real password 
protection) there is no error.

  If I enable password protection in my web.xml the test succed with 
BasicAuthentication, but fails with FormAuthentication (same error as above). 
This make me suspect there is a problem with FormAuthenticaiton as 
implemented by Cactus (but of course, I could be wrong).

  Did anyone manage to make FormAuthentication work with Cactus ? Any idea 
where my problem could be ?

  Thanks for your help !

 Guillaume

On Sunday 20 March 2005 14.17, Guillaume Lederrey wrote:
>   Hello !
>
>   I'm trying to use Cactus to test servlets protected using a FORM
> authentication and JAAS.
>
>   I get the following error when running the test with maven :
>
> 2005-03-20 14:03:43 StandardWrapperValve[ServletRedirectorSecure]:
> Servlet.service() for servlet ServletRedirectorSecure threw exception
> javax.servlet.ServletException: Missing service name parameter
> [Cactus_Service] in HTTP request. Received query string is [].
>
>   In the Tomcat logs, I have :
>
> 2005-03-20 14:03:43 JAASRealm[Standalone]: Username admin successfully
> authenticated
> 2005-03-20 14:03:43 JAASRealm[Standalone]: Username admin has role
> Role.StandardUser
>
> which seems to show that the authentication is not the problem.
>
>   When doing a trace with ethereal, I see that the GET causing the error is
> : GET
> /siems-ds-cactus/ServletRedirectorSecure?Cactus_TestMethod=testCallWithUser
>Principal&Cactus_TestClass=ch.tecost.siems.ds.GetXMLActiveRoleListForLoggedU
>serTest&Cactus_AutomaticSession=true&Cactus_Service=CALL_TEST HTTP/1.1
>
>   It seems to me that the Cactus_Service parameter is given, so I dont
> understand the error message ... Where can I find more informations about
> that ?

Mime
View raw message