jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nitin Padalkar" <Nitin_padal...@persistent.co.in>
Subject MAPPING configuration error for request URI /test/ServletRedirector
Date Sat, 05 Mar 2005 06:52:50 GMT
Hi

I am running cactus tests on jboss3.2.3 using eclipse 3.0. I am using
cactus-ant integration for running the tests.
I have specified <cactus task in my build.xml.But when i run this task,it
automatically starts the container and gives the following error ....

Failed to start the container after more than [60000] ms. Trying to connect
to the
[http://localhost:8080/test/ServletRedirector?Cactus_Service=RUN_TEST] test
URL yielded a [-1] error code. Please run in debug mode for more details
about the error.
Total time: 1 minute 5 seconds

In the server.log it shows MAPPING configuration error for request URI
/test/ServletRedirector ,while deploying my test.war.
When i try to run the above URL directly through browser,i get a blank page
and my server.log shows

2005-03-04 20:36:35,403 DEBUG
[org.apache.cactus.internal.server.ServletImplicitObjects]
<setHttpServletRequest([org.apache.coyote.tomcat4.CoyoteRequestFacade@132590
5])
2005-03-04 20:36:35,403 DEBUG
[org.apache.cactus.internal.server.ServletImplicitObjects]
>setHttpServletRequest
2005-03-04 20:36:35,403 DEBUG
[org.apache.cactus.internal.server.ServletImplicitObjects]
<setHttpServletResponse([org.apache.coyote.tomcat4.CoyoteResponseFacade@725f
0e])
2005-03-04 20:36:35,403 DEBUG
[org.apache.cactus.internal.server.ServletImplicitObjects]
>setHttpServletResponse
2005-03-04 20:36:35,403 DEBUG
[org.apache.cactus.internal.server.ServletImplicitObjects]
<setServletContext([org.apache.catalina.core.ApplicationContextFacade@1d34ea
c])
2005-03-04 20:36:35,403 DEBUG
[org.apache.cactus.internal.server.ServletImplicitObjects]
>setServletContext
2005-03-04 20:36:35,403 DEBUG
[org.apache.cactus.internal.server.ServletImplicitObjects]
<setServletConfig([org.apache.catalina.core.StandardWrapperFacade@1d20651])
2005-03-04 20:36:35,403 DEBUG
[org.apache.cactus.internal.server.ServletImplicitObjects] >setServletConfig
2005-03-04 20:36:35,403 DEBUG
[org.apache.cactus.internal.server.ServletTestController]
<handleRequest([org.apache.cactus.internal.server.ServletImplicitObjects@bea
a01])
2005-03-04 20:36:35,403 DEBUG
[org.apache.cactus.internal.server.ServletUtil]
<getQueryStringParameter([Cactus_Service=RUN_TEST], [Cactus_Service])
2005-03-04 20:36:35,403 DEBUG
[org.apache.cactus.internal.server.ServletUtil] >getQueryStringParameter =
[RUN_TEST]
2005-03-04 20:36:35,403 DEBUG
[org.apache.cactus.internal.server.AbstractWebTestController] Service to
call = RUN_TEST
2005-03-04 20:36:35,419 DEBUG
[org.apache.cactus.internal.ServiceEnumeration] <valueOf([RUN_TEST])
2005-03-04 20:36:35,419 DEBUG
[org.apache.cactus.internal.ServiceEnumeration] >valueOf = [RUN_TEST]
2005-03-04 20:36:35,419 DEBUG
[org.apache.cactus.internal.server.ServletTestController] >handleRequest
2005-03-04 20:36:35,419 DEBUG
[org.apache.cactus.server.ServletTestRedirector] >doPost
2005-03-04 20:36:35,419 DEBUG
[org.apache.cactus.server.ServletTestRedirector] >doGet

Below are the mappings specified in my web.xml

	<servlet>
        <servlet-name>ServletRedirector</servlet-name>

<servlet-class>org.apache.cactus.server.ServletTestRedirector</servlet-class
>
    </servlet>
    <servlet>
        <servlet-name>JspRedirector</servlet-name>
        <jsp-file>/jspRedirector.jsp</jsp-file>
    </servlet>
 <servlet-mapping>
        <servlet-name>ServletRedirector</servlet-name>
        <url-pattern>/ServletRedirector</url-pattern>
    </servlet-mapping>
    <servlet-mapping>
        <servlet-name>JspRedirector</servlet-name>
        <url-pattern>/JspRedirector</url-pattern>
    </servlet-mapping>

Can you please tell me how to resolve the above error?It's very
urgent.Please do the needful by replying ASAP.


Nitin Padalkar


Mime
View raw message