jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Li, Peng" <peng...@eds.com>
Subject Logging issue with <runservertests>
Date Tue, 01 Feb 2005 15:42:08 GMT
> Hi, i have seen some disscusions in the past about logging in cactus and i
> have successful setup the log-properties so that the log works correct
> with Ant <cactus>-tag. The logs were wroten into both client/server_log
> files. 
> 
> I know that <cactus> run test only for localhost, so for remote test i
> tried to use generic <runservertests>. I have put both
> log4j_client.properties(for client side) and log4j.properties(for server
> side) together with cactus.properties into .../WEB-INF/classes. When i run
> <runservertests>, with log4j.debug turned on in both properties, i see
> that during the start phase the log4j.properties(for server side) was
> parsed twice with following messages:
>      [java] log4j: Parsing for [root] with value=[INFO, cactus].
>      [java] log4j: Level token is [INFO].
>      [java] log4j: Category root set to INFO
>      [java] log4j: Parsing appender named "cactus".
>      [java] log4j: Parsing layout options for "cactus".
>      [java] log4j: Setting property [conversionPattern] to [%d %-5p %c
> %C{1} - %M - %m%n].
>      [java] log4j: End of parsing for "cactus".
>      [java] log4j: Setting property [file] to
> [D:/Projects/CATS_LS/cats_ls/cactus/conf/server/cactus_server.log].
>      [java] log4j: Setting property [append] to [false].
>      [java] log4j: setFile called:
> D:/Projects/CATS_LS/cats_ls/cactus/conf/server/cactus_server.log, false
>      [java] log4j: setFile ended
>      [java] log4j: Parsed "cactus" options.
>      [java] log4j: Finished configuring.
> 
> The result is: i can only see the log-infos in cactus_server.log(defined
> in log4j.properties) but not in cactus_client.log(defined in
> log4j_client.properties), there was nothing logged into cactus_client.log.
> 
> Any Idea?
> Thanks in advance
> 
> P.S. i use cactus-13-1.7, Ant-1.6.2 and weblogic8.1SP3. 

Mime
View raw message