jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pandu.Yelamanch...@co.hennepin.mn.us
Subject RE: cactus logging configuration issues
Date Thu, 15 Jul 2004 13:44:40 GMT




I am running the test through browser (Servlet test Runner). Thanks for
your prompt replies.


|---------+---------------------------->
|         |           "Vincent Massol" |
|         |           <vmassol@pivolis.|
|         |           com>             |
|         |                            |
|         |           07/15/2004 02:50 |
|         |           AM               |
|         |           Please respond to|
|         |           "Cactus Users    |
|         |           List"            |
|         |                            |
|---------+---------------------------->
  >------------------------------------------------------------------------------------------------------------------------------|
  |                                                                                      
                                       |
  |       To:       "'Cactus Users List'" <cactus-user@jakarta.apache.org>         
                                             |
  |       cc:                                                                            
                                       |
  |       Subject:  RE: cactus logging configuration issues                              
                                       |
  >------------------------------------------------------------------------------------------------------------------------------|






> -----Original Message-----
> From: Pandu.Yelamanchili@co.hennepin.mn.us
> [mailto:Pandu.Yelamanchili@co.hennepin.mn.us]
> Sent: jeudi 15 juillet 2004 00:48
> To: Cactus Users List
> Subject: RE: cactus logging configuration issues
>
>
>
>
>
> Hi
> Thanks for the suggestions. I only have a server (no client)in my case
> (WAS
> test server running in WSAD). I updated with the 1.6.1 version of cactus.
> So I made the cactus.properties and logging_server.properties.

You also need a logging_client.properties. The reason for the "Not a valid
response" will of course be present in this file! (Cactus client part
calling the Cactus server part).

How are you executing your Cactus tests (browser, Ant, Maven, etc)?

[snip]

> logging_server.properties
> #
>
--------------------------------------------------------------------------
> ---
> # Logging properties
> #
>
--------------------------------------------------------------------------
> ---
>
> # Disable logging by default when running the tests. If you wish to use a
> # logging subsystem, uncomment the line below. That will let Commons
> logging
> # decide automatically of a suitable logging system for you. You can also
> force
> # commons-logging to use a specific logging system. For more info, see
> # http://jakarta.apache.org/commons/logging
>
> # Disable logging
> #org.apache.commons.logging.Log = org.apache.commons.logging.impl.NoOpLog
>
> # Force to use JDK 1.4 logging
> #org.apache.commons.logging.Log =
> org.apache.commons.logging.impl.Jdk14Logger
>
> # Force to use Log4J logging
> #org.apache.commons.logging.Log =
> org.apache.commons.logging.impl.Log4JLogger

Can you uncomment the line to force commons logging to use Log4J logging
which is what you want I think?

[snip]

-Vincent


---------------------------------------------------------------------
To unsubscribe, e-mail: cactus-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: cactus-user-help@jakarta.apache.org





Mime
View raw message