jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vincent Massol" <vmas...@pivolis.com>
Subject RE: Cactus1.6.1 and Ant 1.6.1
Date Mon, 12 Jul 2004 16:58:49 GMT


> -----Original Message-----
> From: Bret Kumler [mailto:bkumler@bitfone.com]
> Sent: lundi 12 juillet 2004 18:46
> To: 'Cactus Users List'
> Subject: RE: Cactus1.6.1 and Ant 1.6.1
> 
> Vincent
> 
> -----Original Message-----
> From: Vincent Massol [mailto:vmassol@pivolis.com]
> Sent: Monday, July 12, 2004 9:41 AM
> To: 'Cactus Users List'
> Subject: RE: Cactus1.6.1 and Ant 1.6.1
> 
> Hi Brett,
> 
> I have checked your log file and I cannot find any problem. Just one
> thing:
> at some point it says "Adding reference: cactus.class.path" and at others
> it
> says "Adding reference: cactus.classpath". Do you really want to have 2
> such
> paths?
> 
> 
> 
> I couldn't find cactus.class.path in my build file.

Have you looked at the log file you sent? It's there. You seem to be
importing some Ant scripts. Maybe it's there?

> I do have cactus.classpath
> 
> 
> 
> 
> Could you also check that the cactus.tasks file is present in the
> ${cactus-ant-jar} jar? (I'd expect it to be there but who knows).
> 
> 
> It's there in the jar file.
> 
> 
> Could you please also verify that the Cactus Ant jar is *NOT* present in
> the
> System classpath, i.e. that it is not present in the Ant classpath.
> 
> 
> It's not in the system classpath or in ant/lib

Just to be sure, if you add the following to your build file:

    <echo>java.class.path = ${java.class.path}</echo>

Is there any Cactus reference in the printed path?

If not, then I'm stuck and you'll need to debug into the Ant code itself...
;-)

[snip]

-Vincent


Mime
View raw message