jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Piotr Godek <Pio...@pbpolsoft.com.pl>
Subject RE: sample servlet test on WebLogic 8.1 problem
Date Fri, 20 Feb 2004 15:21:31 GMT
Hello,

By previous email I mean the one recently sent.

Let me explain it again:
- just running the tests does not work (I checked the filesystem reads with 
NT FilMon and java seems to find the commons-httpclient.jar)
- creating a domain manually, making the war with cactus build.xml, copying
the war manually, 
running weblogic manually and THEN running the tests with ant DOES WORK

in both cases the same war is used, because i actually manually copy the war
created by cactus build.xml to weblogic domain directory

Best regards,
Piotr


-----Original Message-----
From: Kazuhito SUGURI [mailto:suguri.kazuhito@lab.ntt.co.jp]
Sent: Friday, February 20, 2004 3:52 PM
To: cactus-user@jakarta.apache.org
Subject: Re: sample servlet test on WebLogic 8.1 problem


Hi Piotr,

In article
<A2D452E73B9B79479063DC48A5E16AFDB15B01@maverick.pbpolsoft.com.pl>,
Fri, 20 Feb 2004 09:13:30 +0100,
Piotr Godek <PiotrG@pbpolsoft.com.pl> wrote: 
PiotrG> I get the same error over and over again when I run all with the ant
script.
PiotrG> 
PiotrG> If I run the tests the way I described it in my previous email, I
get no
PiotrG> errors.

I may be misunderatanding your messages.
Which email is the your "my previous email" which you described the way
how you run the test and got no errors?


In your first message at 18 Feb 2004 16:57:19 +0100,
you reported error log which contains:
	Caused by: java.lang.NoClassDefFoundError:
org/apache/commons/httpclient/HttpMethod
I had thought that this is a classpath issue, so I suggested you
to put commons-httpclient.jar on your server-side classpath,
at 19 Feb 2004 01:58:51 +0900 (JST).

In second message at 19 Feb 2004 15:49:44 +0100, you had wrote
> Putting the commons-httpclient.jar in any-place-you-can-imagine didn't
work.
You wrote in this second message that you managed to run the test manually,
however, you didn't write "I get no error" but "didn't work".

If the your "my previous email" is the second one,
are you saying that you can run test successfully if you do it manually?
And test still fails with the same error (i.e.
java.lang.NoClassDefFoundError:
org/apache/commons/httpclient/HttpMethod) if you do it with ant script?

If so, (maybe) there are some difference in generated files
(cactified war files for example) between these two ways, I guess.
If this is not your problem, I have no idea now.

Regards,
----
Kazuhito SUGURI
E-mail: suguri.kazuhito@lab.ntt.co.jp

---------------------------------------------------------------------
To unsubscribe, e-mail: cactus-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: cactus-user-help@jakarta.apache.org

Mime
View raw message