jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Newstead" <skankmar...@hotmail.com>
Subject RE: Cactus 12-1.5rc1 & Weblogic 6.1
Date Mon, 26 Jan 2004 20:27:15 GMT
Hi Vince,
I hahe not solved the problem so far but to tell you the truth I have not 
persevered with it. I find myself with a little more time now and renewed 
enthusiasm soI plan to get a much smaller and more controlled environment in 
place on another machine to try to get to know Cactus properly under 'lab' 
conditions, away from the grind of commercial software development.

First I will try with JBoss 3.0.x then port to Weblogic 6.1, do you think 
maybe it is a Weblogic 6.1 specific problem ? I know there were some 
classloader problems with Weblogic 6.1 and I am not sure that my Service 
Pack level fixes them. A clean machine will help me besure of my 
environment.


This is the  first message I have received from the Cactus mailing list, are 
we the only subscribers ?

Thanks for the response
Martin Newstead


>From: "Vincent Massol" <vmassol@pivolis.com>
>Reply-To: "Cactus Users List" <cactus-user@jakarta.apache.org>
>To: "'Cactus Users List'" <cactus-user@jakarta.apache.org>
>CC: <skankmartin@hotmail.com>
>Subject: RE: Cactus 12-1.5rc1 & Weblogic 6.1
>Date: Sun, 25 Jan 2004 19:51:18 +0100
>
>Hi Martin,
>
>Have you solved your issue?
>
>Thanks
>-Vincent
>
> > -----Original Message-----
> > From: Skank Martin [mailto:skankmartin@hotmail.com]
> > Sent: 16 December 2003 12:01
> > To: cactus-user@jakarta.apache.org
> > Subject: Cactus 12-1.5rc1 & Weblogic 6.1
> >
> > I am a newbie with cactus so please bear with me. I have used JUnit in
> > Action and the Cactus docs to build a simple demo web app using the
> > cactify
> > ant task containing a test for one of my server side components. The
>four
> > jars required by cactus are in WEB-INF/lib and my test case under
> > WEB-INF/classes. The war deploys OK in Weblogic, in the console I can
>see
> > the ServletRedirector servlet.
> >
> > When I run a test using the cactus task (& when I paste the URL into a
> > browser) I get the following message in my weblogic console
> >
> > javax.servlet.ServletException: Servlet class:
> > 'org.apache.cactus.server.ServletTestRedirector' cou
> > ld not be loaded - the requested  class wasn't found in the classpath:
> > 'C:\bea\wlserver6.1\config\m
> >
>y21domain\applications\.wlnotdelete\wl_comp9819.war;C:\bea\wlserver6.1\c
>on
> > fig\my21domain\applicatio
> > ns\.wlnotdelete\WEB-
> >
>INF\_tmp_war_myserver_myserver_TestWebClient\cls9820.jar;C:\bea\wlserver
>6.
> > 1\con
> > fig\my21domain\applications\.wlnotdelete\WEB-
> > INF\_tmp_war_myserver_myserver_TestWebClient'
> >
> > Seems it can't find the cactus jar containing ServletTestRedirector,
>it IS
> > in my war when I deploy it.
> >
> > I'd be grateful if anyone can give me any pointers.
> >
> > Martin
> >
> > _________________________________________________________________
> > Browse styles for all ages, from the latest looks to cozy weekend wear
>at
> > MSN Shopping.  And check out the beauty products!
>http://shopping.msn.com
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: cactus-user-unsubscribe@jakarta.apache.org
> > For additional commands, e-mail: cactus-user-help@jakarta.apache.org
>
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: cactus-user-unsubscribe@jakarta.apache.org
>For additional commands, e-mail: cactus-user-help@jakarta.apache.org
>

_________________________________________________________________
Rethink your business approach for the new year with the helpful tips here. 
http://special.msn.com/bcentral/prep04.armx


Mime
View raw message