jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Patwa, Priyank (Cognizant)" <PPriy...@pun.cognizant.com>
Subject RE: Help for using cactus with websphere 4.0 and struts1.0
Date Thu, 20 Nov 2003 11:45:36 GMT
Thanx Neil,
  Sorry for troubling u...
  I have now used all jar's for 1.2 j2ee version and WAS4.0 
i now get the following error 
[03.11.20 17:11:57:808 GMT+05:30] 4f4992a2 WebGroup      X SRVE0026E: [Servlet Error]-[ServletTestRunner]:
java.lang.ClassCastException: org.apache.cactus.server.runner.ServletTestRunner
	at com.ibm.servlet.engine.webapp.WebAppServletManager.loadServlet(WebAppServletManager.java:148)
	at com.ibm.servlet.engine.webapp.WebAppServletManager.getServletReference(WebAppServletManager.java:287)
	at com.ibm.servlet.engine.webapp.WebApp.getServletReference(WebApp.java:354)
	at com.ibm.servlet.engine.webapp.WebAppRequestDispatcherInfo.calculateInfo(WebAppRequestDispatcherInfo.java:130)
	at com.ibm.servlet.engine.webapp.WebAppRequestDispatcherInfo.<init>(WebAppRequestDispatcherInfo.java:46)
	at com.ibm.servlet.engine.webapp.WebApp.getRequestDispatcher(WebApp.java:1133)
	at com.ibm.servlet.engine.srt.WebAppInvoker.handleInvocationHook(WebAppInvoker.java:118)
	at com.ibm.servlet.engine.invocation.CachedInvocation.handleInvocation(CachedInvocation.java:67)
	at com.ibm.servlet.engine.srp.ServletRequestProcessor.dispatchByURI(ServletRequestProcessor.java:122)
	at com.ibm.servlet.engine.oselistener.OSEListenerDispatcher.service(OSEListener.java:315)
	at com.ibm.servlet.engine.http11.HttpConnection.handleRequest(HttpConnection.java:60)
	at com.ibm.ws.http.HttpConnection.readAndHandleRequest(HttpConnection.java:313)
	at com.ibm.ws.http.HttpConnection.run(HttpConnection.java:242)
	at com.ibm.ws.util.CachedThread.run(ThreadPool.java:122)



-----Original Message-----
From: Neil Canham [mailto:neil@knowsense.co.uk]
Sent: Thursday, November 20, 2003 4:41 PM
To: Cactus Users List
Subject: RE: Help for using cactus with websphere 4.0 and struts1.0


Which version of cactus do you have installed?  For WAS4.0 you should be
using jakarta-cactus-12<version>.zip
not the 13 version (12=J2EE 1.2, 13=J2EE 1.3 as supported by WASv5)

regards
Neil Canham
KnowSense Limited

Java and WebSphere Education Services
...yet more sense from Know Sense

-----Original Message-----
From: Patwa, Priyank (Cognizant) [mailto:PPriyank@pun.cognizant.com]
Sent: 20 November 2003 09:43
To: Cactus Users List
Subject: RE: Help for using cactus with websphere 4.0 and struts1.0


Hi Neil,
    thanx for immediate reply.Well as i said i have j2ee.jar that has
servlet version 2.2 also i have the struts1.0
the problem is the class ServletRequestMapper is in v2.3 and so its giving
me teh error

now i tried replacing the j2ee.jar of websphere with the jar from websphere
5.0
this removes this error but i get a new error for which is somewhat like
this:

 <error
message="com/ibm/servlet/personalization/sessiontracking/SessionData.getServ
letContext"
type="org.apache.cactus.client.ServletExceptionWrapper">java.lang.AbstractMe
thodError:
com/ibm/servlet/personalization/sessiontracking/SessionData.getServletContex
t at hansen.playground.ListDVDAction.execute(ListDVDAction.java:19) at
org.apache.struts.action.RequestProcessor.processActionPerform(RequestProces
sor.java:484) at

again i find that the method getServletContext is in version2.3 so its still
complicating things.

Could u please guide me regarding this?

Thanx & Regards,
Priyank Patwa.
Cognizant Technology Solutions India Pvt. Ltd.
Infotech Park,
Hinjawadi,
Pune 411027,
India.
Ph. 2931100 extn: 2476


-----Original Message-----
From: Neil Canham [mailto:neil@knowsense.co.uk]
Sent: Thursday, November 20, 2003 3:03 PM
To: Cactus Users List
Subject: RE: Help for using cactus with websphere 4.0 and struts1.0


Do you have the correct servlet version of StrutsTestCase?  You want the
version for Servlet 2.2, struts 1.0

regards
Neil Canham
KnowSense Limited

Java and WebSphere Education Services
...yet more sense from Know Sense

  -----Original Message-----
  From: Patwa, Priyank (Cognizant) [mailto:PPriyank@pun.cognizant.com]
  Sent: 20 November 2003 09:18
  To: cactus-user@jakarta.apache.org
  Subject: Help for using cactus with websphere 4.0 and struts1.0


  Hi,
      I am trying to write a test case for using cactus with websphere 4.0
and struts1.0. The test case that i have written extends
CactusStrutsTestCase.
  but this gives me a ServletRequestMapper NoClassDefFound error which is
not present in the j2ee.jar of websphere that i have.

  Is it possible to do the same by using some older version of cactus?
  or is there any other possible solution?


  Thanx & Regards,
  Priyank Patwa.
  Cognizant Technology Solutions India Pvt. Ltd.
  Infotech Park,
  Hinjawadi,
  Pune 411027,
  India.
  Ph. 2931100 extn: 2476




---------------------------------------------------------------------
To unsubscribe, e-mail: cactus-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: cactus-user-help@jakarta.apache.org


Mime
View raw message