jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Patwa, Priyank (Cognizant)" <PPriy...@pun.cognizant.com>
Subject RE: Using Cactus StrutsTestCase with WAS 4.0 and struts 1.0 and strutstest-2.0.0.jar. ....help needed
Date Mon, 24 Nov 2003 06:25:52 GMT
Hi Neil,
    Thanx a lot Neil. Sorry for not mentioning the strutstest version.
now i have downloaded the version u recomended and no longer get the ClassCastException for
ServletTestRunner.
also i have removed the servletapi-2.2.jar from my lib.

but know i get the following error. Is 

2003-11-24 11:29:49,632	233187	DEBUG	org.apache.cactus.util.CookieUtil	>createHttpClientCookies
= [[Lorg.apache.commons.httpclient.Cookie;@8324dc3]
2003-11-24 11:29:49,632	233187	DEBUG	org.apache.commons.httpclient.HttpState	enter HttpState.addCookies(Cookie[])
2003-11-24 11:29:49,648	233203	DEBUG	org.apache.cactus.internal.client.WebClientTestCaseDelegate
Exception in test
java.lang.NoSuchMethodError: java.lang.StringBuffer: method append(Ljava/lang/StringBuffer;)Ljava/lang/StringBuffer;
not found
	at org.apache.commons.httpclient.HttpState.toString(HttpState.java:634)
	at java.lang.StringBuffer.append(StringBuffer.java(Compiled Code))
	at java.lang.StringBuffer.append(StringBuffer.java(Compiled Code))
	at org.apache.cactus.util.CookieUtil.createHttpState_aroundBody15$advice(CookieUtil.java:190)
	at org.apache.cactus.util.CookieUtil.createHttpState(CookieUtil.java)
     ......    


And if i include this jar i get the following error:

X Servlet Error-[AdminServlet]: Failed to load servlet: java.lang.ClassCastException: org.apache.axis.transport.http.AdminServlet

Error Page Exception: 
Error Message: class com.ibm.servlet.engine.webapp.DefaultServletConfig does not implement
interface javax.servlet.ServletConfig
Error Code: 500
Target Servlet: JSP 1.1 Processor
Error Stack: 
com.ibm.servlet.engine.webapp.WebAppErrorReport: class com.ibm.servlet.engine.webapp.DefaultServletConfig
does not implement interface javax.servlet.ServletConfig 
     at com.ibm.servlet.engine.webapp.WebAppDispatcherResponse.sendError(WebAppDispatcherResponse.java:97)

     at org.apache.jasper.runtime.JspServlet.unknownException(JspServlet.java:453) 
     at org.apache.jasper.runtime.JspServlet.service(JspServlet.java:552) 
     at javax.servlet.http.HttpServlet.service(HttpServlet.java:853) 


I am unable to understand what is this StringBuffer error that i am getting.
Could u please suggest what mnay the reason.

Sorry for the trouble.

Thanx & Regards,
Priyank Patwa.
Cognizant Technology Solutions India Pvt. Ltd.
Infotech Park,
Hinjawadi,
Pune 411027,
India.
Ph. 2931100 extn: 2476



     

-----Original Message-----
From: Neil Canham [mailto:neil@knowsense.co.uk]
Sent: Saturday, November 22, 2003 7:50 PM
To: Cactus Users List
Subject: RE: Using Cactus StrutsTestCase with WAS 4.0 and struts 1.0
....help needed


As I said in my first reply to you, you need the version of StrutsTestCase
for servlet 2.2, struts 1.0.  Since you have not yet told us what version of
STC you have I will assume you still have the wrong one.
This file is called strutstest200-1.0_2.2.zip, size 2103270 bytes.  Get it
from
http://prdownloads.sourceforge.net/strutstestcase/strutstest200-1.0_2.2.zip?
download

regards
Neil Canham
KnowSense Limited

Java and WebSphere Education Services
...yet more sense from Know Sense

-----Original Message-----
From: Patwa, Priyank (Cognizant) [mailto:PPriyank@pun.cognizant.com]
Sent: 22 November 2003 12:04
To: Cactus Users List
Subject: Using Cactus StrutsTestCase with WAS 4.0 and struts 1.0
....help needed


Hi,
	I have been putting this problem of mine since the past two days ... i got
some replies but am sorry to say still am facxing the same problem
today while going through the FAQ i found that there is

If the NoClassDefFoundError you're receiving complains about either
ServletRequestWrapper or a ServletResponseWrapper, then you are probably
trying to run a version of strutstest.jar that supports Servlet 2.3 in a
Servlet engine that only supports the 2.2 specification. Get the version of
StrutsTestCase appropriate to your test environment.

which is the same that i am getting

My exact configuration is:

   I want to do tesing for my exisisting application developed in struts1.0
and deployed on Websphere 4.0 (J2EE 1.2 servlet v2.2)
also the applictaion uses tiles taglibrary

i have downloaded jakarta-cactus-12-1.5-rc1.zip
and i think i will need the servlettest.jar of version 1.5 (AM NOT SURE
ABOUT THIS)

could u please suggest the jars that i need to use for the same

thanx a lot in advance

Thanx & Regards,
Priyank Patwa.
Cognizant Technology Solutions India Pvt. Ltd.
Infotech Park,
Hinjawadi,
Pune 411027,
India.
Ph. 2931100 extn: 2476




---------------------------------------------------------------------
To unsubscribe, e-mail: cactus-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: cactus-user-help@jakarta.apache.org


Mime
View raw message