jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tarek M. Nabil" <Tarek.Na...@itworx.com>
Subject RE: Strange Problem
Date Sun, 16 Nov 2003 14:28:24 GMT
No, it's not really blocking me at all, I can keep my trivial test case in place. I will also
look further into the issue.

As for the patching thing, do I need to go through CVC and stuff?

-----Original Message-----
From: Vincent Massol [mailto:vmassol@pivolis.com]
Sent: Sunday, November 16, 2003 4:26 PM
To: 'Cactus Users List'
Subject: RE: Strange Problem




> -----Original Message-----
> From: Tarek M. Nabil [mailto:Tarek.Nabil@itworx.com]
> Sent: 16 November 2003 15:18
> To: Cactus Users List
> Subject: RE: Strange Problem
> 
> Hi Vincent,
> 
> First I'd like to thank you for your reply to my other question. I
really
> never went that far down that page :)
> 
> I'd like to suggest adding a hint to the "writing\howto_security.html"
> page, to suggest that the procedure described can also be automated
with
> CactifyWar. If you think this is a good idea, I can volunteer to do
it.
> 

yeah, that would be nice! :-) A patch would be nice.

> As for this question, I do see that this is the error cause. But
what's
> strange is that, the error disappears when I add the trivial test,
> eventhough, the trivial test does not even instantiate the filter.
Plus,
> up in the logs, it's obvious, the filter did return a response.

I don't know. Sorry, I don't have the time right now to debug this
issue. I hope you're not blocked by it. If, after some more research,
you still think it's a bug please file a Cactus bugzilla bug so that it
is recorded and we do not forget to fix it in due time.

There are some Cactus tests testing the filter redirector in the cactus
sample application.

Thanks
-Vincent

> 
> Thanks,
> Tarek Nabil
> 
> -----Original Message-----
> From: Vincent Massol [mailto:vmassol@pivolis.com]
> Sent: Sunday, November 16, 2003 4:01 PM
> To: 'Cactus Users List'
> Subject: RE: Strange Problem
> 
> 
> Hi Tarek,
> 
> It seems to me your problem comes from your filter test. I'm not a
> filter expert and I've not taken the time to analyze it. Here's the
> relevant portion in the log:
> 
> [snip]
> 
> > org.apache.cactus.server.FilterTestRedirector - >doFilter
> > DEBUG 2003-11-16 15:24:22,005 httpclient.wire           - <<
"HTTP/1.1
> 500
> > Internal Server Error[\r][\n]"
> > DEBUG 2003-11-16 15:24:22,005 httpclient.wire           - <<
"Content-
> > Type: text/xml; charset=UTF-8[\r][\n]"
> > DEBUG 2003-11-16 15:24:22,005 httpclient.wire           - << "Date:
> Sun,
> > 16 Nov 2003 13:24:20 GMT[\r][\n]"
> > DEBUG 2003-11-16 15:24:22,005 httpclient.wire           - <<
> "Transfer-
> > Encoding: chunked[\r][\n]"
> > DEBUG 2003-11-16 15:24:22,005 httpclient.wire           - <<
"Server:
> > Apache Tomcat/4.1.27 (HTTP/1.1 Connector)[\r][\n]"
> > DEBUG 2003-11-16 15:24:22,015 httpclient.wire           - <<
> "Connection:
> > close[\r][\n]"
> > WARN  2003-11-16 15:24:22,015
> org.apache.commons.httpclient.HttpMethodBase
> > - Chunk-encoded body missing
> 
> [snip]
> 
> It seems your filter is failing to return the body content somehow.
> 
> -Vincent
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: cactus-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: cactus-user-help@jakarta.apache.org
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: cactus-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: cactus-user-help@jakarta.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: cactus-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: cactus-user-help@jakarta.apache.org


Mime
View raw message