jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Flagg, Kenneth BGI SF" <Kenneth.Fl...@barclaysglobal.com>
Subject JBoss, Cactus 1.5-b1, and JAAS - problem solved
Date Tue, 14 Oct 2003 19:44:20 GMT
Sorry if I've posted a lot of messages to this list, but I was truly
flummoxed.  Anyhow, I have fixed my problem, and my solution may be of use
to other Cactus/JBoss users.

I copied the jboss-web.xml file from samples\servlet\src\conf\jboss3x to the
META-INF directory of my cactified WAR, and voila! my test case worked.  It
does not appear that this is documented anywhere.  I'm assuming that my woes
have been a result of cactus 1.5's new authentication features.  I'm using
custom form-based auth on my site and therefore have not utilized nor
configured simple HTTP auth or JAAS.

Anyhow, I hope this is of help to other JBoss/Cactus users who find
themselves in the same boat.

Thanks,
Ken Flagg 

p.s. What is the default security-related behavior for Cactus 1.5?

Mime
View raw message