jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Per Olesen" <pole...@nordija.com>
Subject RE: Cactus and weblogic
Date Thu, 16 Oct 2003 07:22:21 GMT
Hi Mark,

Mark Lybarger said:
>
> can you post your specific NoClassDefFoundError that you see in your
> weblogic logs? And perhaps a sample of how you're running your tests?

Certainly. This is the exception we saw. It happened when wls were
deploying the webapp, which was cactified. It seems to be when it deploys
the filter.


java.lang.NoClassDefFoundError: org/apache/commons/logging/LogFactory
        at
org.apache.cactus.server.FilterTestRedirector.<clinit>(FilterTestRedirector.java;org/apache/cactus/util/log/LogAspect.aj[1k]:87)
        at java.lang.Class.newInstance0(Native Method)
        at java.lang.Class.newInstance(Class.java:237)
        at
weblogic.servlet.internal.WebAppServletContext.registerFilter(WebAppServletContext.java:1943)
....


The filter depends upon commons-logging, which we also had in WEB-INF/lib
of the webapp.

BTW: Inside commons-logging.jar, there is a manifest with a Class-Path
ref, which refs a log4j.jar and log4j-core.jar. The log4j-core.jar we
could not find, but we also tried adding log4j.jar to WEB-INF/lib to no
avail.

We are aware, that wls uses a three-level classloader hierarchy, with the
system classloader at top, the ejb-classloader in the middle and the
webapp classloader in the bottom. So we though it might be because we had
some classes in the system or ejb classloader, which would confuse it
about where to find the classes it needs !?

Actually, we tried adding the commons-logging jar to system classloader,
which made it find it ok. Then it was just another class which it could
not find :-( But we will not add all classes to the system classloader.

Does this help in diagnosing the problems?

Actually, we are looking into upgrading wls at some point in the future.
Found out the wls6.1 does not support ejb-local-ref element in web.xml,
even though it is part of J2EE1.3 spec. So we are unable to test EJBLocal
beans from cactus in wls6.1. This makes me sad ;-(


Regards, Per


Mime
View raw message