jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sam smith <samtsm...@yahoo.com>
Subject Having trouble with Cactus Ant and WebSphere 5.0
Date Mon, 20 Oct 2003 23:06:32 GMT
I'm trying to use the Cactus ANT tasks to run our unit tests on WebSphere 5.0.  However, I
have not been able to get the <cactus> task to use the correct URL to determine that
the server is running.  The start task is working correctly (i.e. it is starting the app server),
but the <cactus> task is timing out.
 
When using the defaults, these appear in the access log of the web server:
 
127.0.0.1 - - [20/Oct/2003:17:21:56 -0500] "GET //FOTWWebApp/ServletRedirector?C
actus_Service=RUN_TEST HTTP/1.1" 404 313
 
The issues for us are:
(1) It appears as though Cactus is adding a "/", then our context root "/FOTWWebApp" is being
added.
(2) The app server should be accessed via HTTPS
 
The URL we need Cactus to poll is 
https://localhost:8443/FOTWWebApp/ServletRedirector?Cactus_Service=RUN_TEST.  I've tried setting
"cactus.contextURL=https://localhost:8443/FOTWWebApp" and "cactus.contextURL=https://localhost"
using -D and in a properties file.  However, I get the same result as above.
 
I've also tried adding the port=8443 attribute to the <generic> task.  However, when
I do this, nothing shows up in my access log.
 
Any idea what I am doing wrong?
 
Thanks,
Sam
 



---------------------------------
Do you Yahoo!?
The New Yahoo! Shopping - with improved product search
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message