jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Silverstein" <msilverst...@silvermark.com>
Subject Extraneous reference to FilterTestRedirector in web.xml
Date Wed, 08 Oct 2003 01:36:02 GMT
Christopher:

That did it! You get the genius award for saving me days of effort and
countless brain cells. I'd scavenged a web.xml from somewhere that had
apparently had an incorrect DOCTYPE set in it. I pasted the following in
and everything works just fine now:

<!DOCTYPE web-app
    PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.2//EN"
    "http://java.sun.com/j2ee/dtds/web-app_2_2.dtd">


Thanks!

------------------------------------------------------------------------
--------

Christopher Lenz  wrote:

Hi Michael,

is it possible that you're using the Cactus JAR for J2EE 1.2 but
cactifying a WAR that is declared as J2EE 1.3 (as specified by the
DOCTYPE in the web.xml)?

-chris
------------------------------------------------------------------------
--------
Michael Silverstein wrote: 
I am running into a problem deploying a 'cactified' application on
Tomcat 4 with the cactus 1.5 beta. The build process keeps putting a
reference to org.apache.cactus.server.FilterTestRedirector into my
web.xml, even thought that class is not included in
cactus-1.5-beta1.jar, so I get a class not found exception starting
Tomcat. Here is what it looks like:

<filter>
<filter-name>FilterRedirector</filter-name>
<filter-class>org.apache.cactus.server.FilterTestRedirector</filter-clas
s>
</filter>
<filter-mapping>
<filter-name>FilterRedirector</filter-name>
<url-pattern>/FilterRedirector</url-pattern>
</filter-mapping>


Oddly, when I build and run the sample servlet tests it does not put
that into the web.xml file so it is fine. My build.xml file is derived
from and nearly identical to the sample servlet build.xml file. If,
after running the ant build, I remove the above from the generated
web.xml everything is fine.

I tried searching all the files in the cactus distribution to see if
there are any explicit references to that code and only found it in
\integration\ant\src\confs\j2ee13\web.xml. I commented it out and still
get the reference in my build.xml. 


There is something that specifies whether to put that reference in the
web.xml but I can't figure out what so I can turn it off.

What am I doing wrong?

Thanks, Mike 

---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.522 / Virus Database: 320 - Release Date: 9/29/2003
 


Mime
View raw message