jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bret Kumler" <bkum...@firstam.com>
Subject task
Date Tue, 23 Sep 2003 21:30:31 GMT
I have the following in build.xml (see below), but for some reason, it
starts the server & never executes the test & never shuts down the server.
Any ideas?

Thanks


<target name="test" depends="start.weblogic.81" description="Run the tests
on the defined containers">
                <!-- Run the tests -->
                <cactus earfile="${target.dir}/${test.file}" fork="yes"
failureproperty="tests.failed">
                        <classpath>
                                <path refid="project.classpath"/>
                                <pathelement
location="${base.dir}/${modification.location}/${path-to-new-pmjws-web.xml}/
lib/qa-test.jar"/>
                        </classpath>
                        <containerset>
                                <generic name="Weblogic 8.1.1"
port="${test.port}">
                                        <startup
target="start.weblogic.81"/>
                                        <shutdown
target="stop.weblogic.81"/>
                                </generic>
                        </containerset>
                        <formatter type="brief" usefile="false"/>
                        <formatter type="xml"/>
                        <batchtest>
                                <fileset dir="${pm.test.src}">
                                        <include name="**/Qa*.java"/>
                                        <exclude name="**/Qa*All.java"/>
                                </fileset>
                        </batchtest>
                </cactus>
                <!-- Generate the JUnit reports -->
                <junitreport
todir="${base.dir}/${modification.location}/weblogic8x">
                        <fileset
dir="${base.dir}/${modification.location}/weblogic8x"
includes="TEST-*.xml"/>
                        <report
todir="${base.dir}/${test.reports.loc}/weblogic8x" format="frames"/>
                </junitreport>
                <fail if="tests.failed">At least one test failed!</fail>
        </target>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message