jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Billy Bacon <billy.ba...@thirty3.net>
Subject Re: Problem with Ant Integration (and workaround)
Date Tue, 30 Sep 2003 15:00:19 GMT
I read the entry from the archives regarding this issue ("Couldn't find
tools.jar ...")  since I just joined the mailing list a few days ago and I'm
having the same issue that was described...

Question 1:
===========
The sample build file comes with the following pathelement...
<pathelement location="${java.home}/../lib/tools.jar"/> which slightly
confuses me b/c of the "../" in the location. My tools.jar is located in
$JAVA_HOME/lib/ so why is it that there is a "../" in the location? I tried
testing this by using the copyfile task from ant and fed it the
${java.home}/../lib/tools.jar file for the 'file' attribute and the build
failed saying it couldn't find tools.jar in that location.


Question 2:
===========
Originally I didn't have the tools.jar in my java home lib directory but I
then copied it there and when I start up Ant with -verbose on the tools.jar
is in my Classpath but I still get this error. Does anyone know why this
would be happening?

Thanks for any help.

- Billy -


Mime
View raw message