jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vincent Massol" <vmas...@pivolis.com>
Subject RE: RE : RE : Error using maven cactus plugin with StrutsTestCase and Weblogic 7
Date Sat, 13 Sep 2003 18:53:26 GMT
Hi Sebastien,

Do you now have everything working? Any remaining issues with WebLogic
and Cactus?

Thanks
-Vincent

> -----Original Message-----
> From: BRUNOT Sébastien [mailto:Sebastien.BRUNOT@vizzavi.fr]
> Sent: 03 July 2003 13:53
> To: 'Cactus Users List'
> Subject: RE : RE : Error using maven cactus plugin with StrutsTestCase
and
> Weblogic 7
> 
> I tried to run the cactus target with maven beta-10 (checkout this
> morning),
> wich come with version 3.0-SNAPSHOT of the cactus plugin... This
version
> can't do any automatised test with weblogic :-(
> 
> Do you have a cactus-framework jar that doesn't have the
> AbstractHttpServletRequestWrapper package problem, that i could copy
in my
> local repository under the name
"cactus-framework-13-1.5dev-20030407.jar"
> so
> that it will be used by cactus plugin ? Seems to be the only solution,
> right
> now, to my problem...
> 
> Sebastien BRUNOT
> 
> -----Message d'origine-----
> De : Vincent Massol [mailto:vmassol@pivolis.com]
> Envoyé : jeudi 3 juillet 2003 10:24
> À : 'Cactus Users List'
> Objet : RE: RE : Error using maven cactus plugin with StrutsTestCase
and
> Weblogic 7
> 
> 
> 
> 
> > -----Original Message-----
> > From: BRUNOT Sébastien [mailto:Sebastien.BRUNOT@vizzavi.fr]
> > Sent: 03 July 2003 10:10
> > To: 'Cactus Users List'
> > Subject: RE : Error using maven cactus plugin with StrutsTestCase
and
> > Weblogic 7
> >
> > OK, I can try this, even if it looks like a temporary solution...
> >
> > Where can i download a beta 10 snapshot ?
> 
> 1/ Perform a CVS checkout of Maven (see
> http://maven.apache.org/cvs-usage.html)
> 2/ Make sure you have Ant installed on your machine.
> 3/ Create a MAVEN_HOME env variable pointing to where you want Maven
> installed 4/ type "ant -f build-bootstrap.xml" in the maven directory
> where
> you checked out maven
> 
> For more info, see http://maven.apache.org/start/bootstrap.html
> 
> >
> > Last question : what will be the definitive package for
> > HttpRequestWrapper, org.apache.cactus.server or
> > org.apache.cactus.server.wrapper ?
> 
> o.a.c.s
> 
> Thanks
> -Vincent
> 
> >
> > -----Message d'origine-----
> > De : Vincent Massol [mailto:vmassol@pivolis.com]
> > Envoyé : mercredi 2 juillet 2003 19:46
> > À : 'Cactus Users List'
> > Objet : RE: Error using maven cactus plugin with StrutsTestCase and
> > Weblogic 7
> >
> >
> > Hi Sebastien,
> >
> > The easiest solution to solve your problem is to upgrade to a newer
> > version of the Maven plugin for Cactus. However, that may involve
> > moving from Maven
> > beta 9 to beta 10 (from CVS at the moment) - This issue has been
fixed
> in
> > CVS HEAD of Maven.
> >
> > FYI, the issue is with StrutsTestCase/Cactus. Strutestcase is
calling
> a
> > class that we had temporarily moved in a nightly build of Cactus
> (Cactus
> > 1.5). The Maven plugin for Cactus is using Cactus 1.5dev, hence the
> > problem.
> >
> > Thanks and sorry for the inconvenience.
> > -Vincent
> >
> > > -----Original Message-----
> > > From: BRUNOT Sébastien [mailto:Sebastien.BRUNOT@vizzavi.fr]
> > > Sent: 02 July 2003 18:53
> > > To: 'cactus-user@jakarta.apache.org'
> > > Subject: Error using maven cactus plugin with StrutsTestCase and
> > Weblogic
> > > 7
> > >
> > > Hello,
> > >
> > > Precedent mail was in HTML... Sorry :-(
> > >
> > > Here is the thread :
> > >
> > > I've got a problem with maven 1.0 beta 9 cactus plugin :
> > >
> > > I have a Struts 1.1 webApp and a StrutsTestCase i'd like to run on
> > > weblogic 7.
> > >
> > > I've got the following line in project.properties :
> > >
> > > cactus.home.weblogic7x=C:\bea
> > >
> > > I've declared a dependency with strutstestcase in my project.xml :
> > >
> > >     <dependency>
> > >       <id>strutstestcase</id>
> > >       <version>2.0-1.1-2.3</version>
> > >       <properties>
> > >         <war.bundle.jar>true</war.bundle.jar>
> > >       </properties>
> > >     </dependency>
> > >
> > > When i run "maven cactus", my webapp seems to be correctly
> > "catus-fied",
> > > but
> > > I've got the following error :
> > >
> > >     [java] <2 juil. 03 18:31:43 CEST> <Notice> <WebLogicServer>
> > <000331>
> > > <Starte d WebLogic Admin Server "testserver" for domain
"testdomain"
> > > running in Developm ent Mode>
> > >     [java] <2 juil. 03 18:31:44 CEST> <Error> <HTTP> <101018>
> > > <[ServletContext(i
> > d=7683425,name=cactustest,context-path=/cactustest)]
> > > Servlet failed with Servlet Exception
> > >     [java] javax.servlet.UnavailableException:
> > > ServletContext(id=7683425,name=ca
> > > ctustest,context-path=/cactustest): The server testserver is
> > temporarily
> > > suspend ed
> > >     [java]      at
> > > weblogic.servlet.internal.WebAppServletContext.invokeServlet(
> > > WebAppServletContext.java:3096)
> > >     [java]      at
> > > weblogic.servlet.internal.ServletRequestImpl.execute(ServletR
> > > equestImpl.java:2588)
> > >     [java]      at
> > > weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:213)
> > >     [java]      at
> > > weblogic.kernel.ExecuteThread.run(ExecuteThread.java:189)
> > >     [java] >
> > >     [java] <2 juil. 03 18:31:44 CEST> <Notice> <WebLogicServer>
> > <000365>
> > > <Server  state changed to RUNNING>
> > >     [java] <2 juil. 03 18:31:44 CEST> <Notice> <WebLogicServer>
> > <000360>
> > > <Server  started in RUNNING mode>
> > >     [junit] Running
com.sfr.octotests.modulestruts.SimpleActionTest
> > >     [junit] java.lang.NoClassDefFoundError:
> > > org/apache/cactus/server/AbstractHtt
> > > pServletRequestWrapper
> > >     [junit]     at java.lang.Class.forName0(Native Method)
> > >     [junit]     at java.lang.Class.forName(Class.java:115)
> > >     [junit]     at
> > > org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.
> > > <init>(JUnitTestRunner.java:237)
> > >     [junit]     at
> > > org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.
> > > <init>(JUnitTestRunner.java:210)
> > >     [junit]     at
> > > org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.
> > > main(JUnitTestRunner.java:520)
> > >     [junit] Exception in thread "main"
> > >     [junit] [ERROR] TEST
> > com.sfr.octotests.modulestruts.SimpleActionTest
> > > FAILED
> > >
> > > Anyone got an idea ? seems to me that the
> > > org.apache.cactus.server.AbstractHttpServletRequestWrapper
> > > Doesn't exist (the correct package name is
> > > org.apache.cactus.server.wrapper). Is it a version problem ?
> > >
> > > For info, i've got the same problem with Tomcat 4.1.
> > >
> > > Sebastien BRUNOT
> > >
> > >
> ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: cactus-user-unsubscribe@jakarta.apache.org
> > > For additional commands, e-mail:
cactus-user-help@jakarta.apache.org
> >
> >
> >
> >
---------------------------------------------------------------------
> > To unsubscribe, e-mail: cactus-user-unsubscribe@jakarta.apache.org
> > For additional commands, e-mail: cactus-user-help@jakarta.apache.org
> >
> >
---------------------------------------------------------------------
> > To unsubscribe, e-mail: cactus-user-unsubscribe@jakarta.apache.org
> > For additional commands, e-mail: cactus-user-help@jakarta.apache.org
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: cactus-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: cactus-user-help@jakarta.apache.org
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: cactus-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: cactus-user-help@jakarta.apache.org



Mime
View raw message