jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From BRUNOT Sébastien <Sebastien.BRU...@cegetel.fr>
Subject RE : RE : RE : Maven cactus plugin regression (?)
Date Tue, 05 Aug 2003 13:34:03 GMT
Oups,

I was too quick... It doesn't work with the BEA_HOME setting... Sorry :-(

Sebastien

-----Message d'origine-----
De : BRUNOT Sébastien [mailto:Sebastien.BRUNOT@cegetel.fr] 
Envoyé : mardi 5 août 2003 15:33
À : 'Cactus Users List'
Objet : RE : RE : Maven cactus plugin regression (?)


Hi,

Everything is working fine when i set up a BEA_HOME environment variable...

Wouldn't it be possible that the plugin use cactus.home.weblogic7x value
instead of BEA_HOME ?

Sebastien BRUNOT

-----Message d'origine-----
De : Vincent Massol [mailto:vmassol@pivolis.com] 
Envoyé : mardi 5 août 2003 14:54
À : 'Cactus Users List'
Objet : RE: RE : Maven cactus plugin regression (?)


Strange error. Ok, you've won, I'm installing WL 7.x now...

-Vincent

> -----Original Message-----
> From: BRUNOT Sébastien [mailto:Sebastien.BRUNOT@cegetel.fr]
> Sent: 05 August 2003 14:00
> To: 'Cactus Users List'
> Subject: RE : Maven cactus plugin regression (?)
> 
> Hi,
> 
> I've been testing the 3.1-SNAPSHOT from HEAD with maven b10, and here
is
> the
> resulting
> Error i get :
> 
> cactus:init:
>     [mkdir] Created dir:
> C:\Work\CVS\octotest\modules\moduleStruts\target\test-c
> actus-reports
>     [mkdir] Created dir: 
> C:\Work\CVS\octotest\modules\moduleStruts\target\test-c
> actus-reports\weblogic7x
> 
> cactus:compile:
>     [mkdir] Created dir:
> C:\Work\CVS\octotest\modules\moduleStruts\target\test-c
> actus-classes
>     [javac] Compiling 1 source file to 
> C:\Work\CVS\octotest\modules\moduleStruts
> \target\test-cactus-classes
> 
> cactus:cactifywar:
>     [cactifywar] Analyzing war:
> C:\Work\CVS\octotest\modules\moduleStruts\target
> \moduleStruts.war
>     [cactifywar] Building war: 
> C:\Work\CVS\octotest\modules\moduleStruts\target\
> moduleStruts-cactus.war
> 
> cactus:test:
>     [cactus]
> -----------------------------------------------------------------
>     [cactus] Running tests against WebLogic 7.x
>     [cactus]
> -----------------------------------------------------------------
>     [cactus] Building jar:
> C:\DOCUME~1\brunots\LOCALS~1\Temp\cactus\weblogic7x\t
> estdomain\applications\moduleStruts-cactus.war
> java.lang.NullPointerException
>         at 
> org.apache.tools.ant.types.Environment$Variable.setFile(Environment.j
> ava:97)
>         at 
> org.apache.cactus.integration.ant.container.AbstractJavaContainer.cre
> ateSysProperty(AbstractJavaContainer.java:155)
>         at 
> org.apache.cactus.integration.ant.container.weblogic.WebLogic7xContai
> ner.startUp(WebLogic7xContainer.java:206)
>         at 
> org.apache.cactus.integration.ant.container.ContainerRunner$1.run(Con
> tainerRunner.java:185)
>         at java.lang.Thread.run(Thread.java:479)
> 
> BUILD FAILED
> File...... file:/C:/Documents and
> Settings/brunots/.maven/plugins/maven-cactus-p
> lugin-3.1-SNAPSHOT/
> Element... cactus
> Line...... 227
> Column.... 53
> Failed to start the container after more than [180000] ms. Total time: 
> 4 minutes 48 seconds
> 
> -----Message d'origine-----
> De : Vincent Massol [mailto:vmassol@pivolis.com]
> Envoyé : mardi 5 août 2003 12:35
> À : 'Cactus Users List'
> Cc : Sebastien.BRUNOT@cegetel.fr
> Objet : RE: Maven cactus plugin regression (?)
> 
> 
> Hi Sebastien,
> 
> You're right, support for WL7.x has been inadvertently dropped in
version
> 3.0 when we moved to the new Cactus/Ant integration. I have added it
back
> in
> version 3.1-SNAPSHOT in CVS HEAD. However, I've not been able to test
it
> as
> I don't have WL7 on my machine.
> 
> Do you think you could give it a try?
> 
> Thanks
> -Vincent
> 
> > -----Original Message-----
> > From: BRUNOT Sébastien [mailto:Sebastien.BRUNOT@cegetel.fr]
> > Sent: 01 August 2003 11:23
> > To: 'Cactus Users List'; 'users@maven.apache.org'
> > Subject: Maven cactus plugin regression (?)
> >
> > Hi,
> >
> > Seems to me that there is a regression in cactus plugin 3.0 : it was
> > possible with cactus plugin 2.0 to test the webapp in a Weblogic 7 
> > container, it doesn't seems to work with the new plugin...
> >
> > Anybody else got the same problem ?
> >
> > Sebastien BRUNOT
> >
> >
---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> > For additional commands, e-mail: users-help@maven.apache.org
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: cactus-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: cactus-user-help@jakarta.apache.org
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: cactus-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: cactus-user-help@jakarta.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: cactus-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: cactus-user-help@jakarta.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: cactus-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: cactus-user-help@jakarta.apache.org

Mime
View raw message