jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aaron Humphrey" <Humphr...@Kakari.com>
Subject Re: Error instantiating class with 1.5b1
Date Thu, 17 Jul 2003 15:25:22 GMT


>>> Christopher Lenz <cmlenz@gmx.de> 07/15/03 04:27PM >>>
> Hi Aaron,

> Aaron Humphrey wrote:
> > I've been having problems with Cactus and StrutsTestCase, so I thought I'd download
the new version, beta though it is.
> > 
> > Now, unfortunately, it can't even instantiate my classes.  What I get when I try
to run my CactusStrutsTestCase tests is:
> > 
> > ERROR [AbstractWebTestCaller] Error instantiating class [my.test.class.name([myTestName],
[null])]
> > java.lang.reflect.InvocationTargetException
> > 
> > in my Jboss/Tomcat log, and
> > 
> > javax.servlet.ServletException: Error instantiating class [my.test.class.name([myTestName],
[null])]
> >   at org.apache.cactus.server.AbstractWebTestCaller.getTestClassInstance(AbstractWebTestCaller.java:459)
> > 
> > (I'd provide more info if either my command window or my jUnit window provided cut
& paste...)

> I suspect there must be a root cause printed further down in the stack 
> trace... without more details it is really hard to help.

> You should be able to copy from the command line BTW, except you're in a 
> rather exotic environment ;-)

I don't know, does a Windows XP pseudo-DOS window count?

In any event, you were right; I'd missed it at first because of long lines wrapping at 80
columns, but the source of the error
was because of a missing class from commons-httpclient.  Because I hadn't put commons-httpclient
into my WAR file.  Oops...
Still, it _had_ worked under Cactus 1.4.1 without it.

> > These tests worked under Cactus 1.4.1.  I updated all the appropriate .jar files
with the ones from the 1.5b1 distribution.
> > 
> > I was hoping that the new version might fix the problem I was having with 1.4.1,
where running my CactusStrutsTestCase
> > would somehow screw up my JSP's <html:form action="..." mapping.

> That sounds more like a problem with StrutsTestCase.

Yes, well, on the StrutsTestCase forum, they said it sounded like Cactus.  :-)  Nobody's claiming
it to be a Struts problem, at
least...

I don't really think I'm equipped to try to debug the problem myself yet, though.


Aaron V. Humphrey
Kakari Systems Ltd.



Mime
View raw message