jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From dmk...@earthlink.net (David M. Karr)
Subject Re: WebResponse.getHeaderField() no longer contains inserted headers
Date Tue, 22 Jul 2003 04:49:23 GMT
>>>>> "David" == David M Karr <dmkarr@earthlink.net> writes:

    David> In the past, I've built Cactus tests where I call
    David> "HttpServletResponse.addHeader()" in my "test..." method, in order to
    David> communicate to my "end..." method some information I need to check for (since
    David> there's no other practical way for the "test..." method to communicate to the
    David> "end..." method).  In my "end..." method, I use "WebResponse.getHeaderField()"
    David> to retrieve the header with an agreed-upon key.

    David> This was working with Cactus 1.3.

    David> I've now updated to 1.5beta1 (because this appears to be the "current"
    David> release).  My tests are now failing because the call to
    David> "WebResponse.getHeaderField()" is not finding the header.  Just to check, I
    David> tried looping through the result of "WebResponse.getHeaderFieldNames()", and
I
    David> find that it does have some headers, just not the one I inserted on the
    David> "client" side.

    David> Has this machinery changed such that I have to do this differently, or is this
    David> just a bug in the beta release?

I've now tried backing up to Cactus 1.4.1, with the same result.  I don't
understand what I could be doing wrong.

-- 
===================================================================
David M. Karr          ; Java/J2EE/XML/Unix/C++
dmkarr@earthlink.net   ; SCJP; SCWCD




Mime
View raw message