jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eric Cestari [Ohm Force]" <e...@ohmforce.com>
Subject Eclipse plugin fix
Date Sat, 26 Jul 2003 13:10:15 GMT
Hi all,

I had a problem, reported by several users. The eclipse plugin was not 
recognized.
The eclipse log file :
-----
!MESSAGE Problems encountered loading the plug-in registry.
!SUBENTRY 1 org.eclipse.core.runtime 2 1 juil. 25, 2003 15:53:26.454
!MESSAGE Error while processing 
"file:E:/eclipse/plugins/org.apache.cactus.eclipse.runner_20030722/plugin.xml:  
assertion failed: The major (1st) component of plug-in version 
identifier, "${project.version.plugin}", must be numeric.".
-------
This is due to the plugin.xml <plugin> not correctly written.
The version attribute is not parsed correctly.

Change the opening tag to :
<plugin
   id="org.apache.cactus.eclipse.runner"
   name="Cactus"
   version="1.5"
   provider-name="Jakarta Cactus"
   class="org.apache.cactus.eclipse.runner.ui.CactusPlugin">

(You might adjust to the real values the Cactus team will certainly give 
you, but the fix is good).
Thanks to Chris Lenz for telling to check the .log eclipse file !

Best regards,
    Eric Cestari

http://www.ohmforce.com
Designing Home Studio


Mime
View raw message