jakarta-cactus-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Lenz <cml...@gmx.de>
Subject Re: Error instantiating class with 1.5b1
Date Tue, 15 Jul 2003 22:31:31 GMT
Just to avoid confusion here, Cactus 1.5-beta1 is not 100% binary 
compatible with Cactus 1.4.1, but it should be possible to use 
StrutsTestCase 2.0 without problems (and without recompilation of 
StrutsTestCase itself). At least it worked in all my tests :-P

-chris

Bastian Bowe wrote:
> Don't know much about cactus jet, but according to the 1.5-beta1
> announcment from Vincent on this mailing list you have to recompile
> all classes. Search for "AbstractWeb" in his mail for details.
> 
> Regards
> 
> On Tue, Jul 15, 2003 at 03:47:03PM -0600, Aaron Humphrey wrote:
> 
>>I've been having problems with Cactus and StrutsTestCase, so I thought I'd download
the new version, beta though it is.
>>
>>Now, unfortunately, it can't even instantiate my classes.  What I get when I try to
run my CactusStrutsTestCase tests is:
>>
>>ERROR [AbstractWebTestCaller] Error instantiating class [my.test.class.name([myTestName],
[null])]
>>java.lang.reflect.InvocationTargetException
>>
>>in my Jboss/Tomcat log, and
>>
>>javax.servlet.ServletException: Error instantiating class [my.test.class.name([myTestName],
[null])]
>>  at org.apache.cactus.server.AbstractWebTestCaller.getTestClassInstance(AbstractWebTestCaller.java:459)
>>
>>(I'd provide more info if either my command window or my jUnit window provided cut
& paste...)
>>
>>These tests worked under Cactus 1.4.1.  I updated all the appropriate .jar files with
the ones from the 1.5b1 distribution.
>>
>>I was hoping that the new version might fix the problem I was having with 1.4.1, where
running my CactusStrutsTestCase would somehow screw up my JSP's <html:form action="...">
mapping.
>>
>>
>>Aaron V. Humphrey
>>Kakari Systems, Ltd.

-- 
Christopher Lenz
/=/ cmlenz at gmx.de


Mime
View raw message